Need to disable dirty read on PDO_MYSQL connection

For programming and general questions on Zend Framework

Need to disable dirty read on PDO_MYSQL connection

Postby michaelscook on Wed Dec 19, 2012 10:27 pm

I am writing an application using framework 1.11.11, and a database with the PDO_MYSQL adapter. When I attempt to perform a fetchAll call, I get the following error:

SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'UR' at line 1

When I review the MySQL query log, I see that it is appending 'WITH UR' at the end. I see from looking at the library that the query is attempting to read uncommitted records, but is using an unsupported syntax to do so.

I've gone over the documentation, but I can't seem to find how I would disable this option. Is this something handled in the config, or do I have to use a method call?
michaelscook
 
Posts: 8
Joined: Wed Dec 19, 2012 10:19 pm

Return to Zend Framework

Who is online

Users browsing this forum: No registered users and 8 guests

cron