Zend_Search_Lucene can't read index

For programming and general questions on Zend Framework
Post Reply
Posts: 2
Joined: Mon Nov 22, 2010 12:32 pm

Zend_Search_Lucene can't read index

Post by hapablap » Mon Nov 22, 2010 1:03 pm

Hi everyone,

I programmed a Zend Search Lucene server application that runs with SOAP. You can simply add Documents to the index and search. I programmed it on my Macbook and everythink worked fine. Now I wanted to run this application on a server in our company's network and get some problems. The SOAP connection works fine. But when I create the index, I return an int value of the index size. Here's the first problem: I get back nothing. Then I try to search the index: I get no results. I tried to open the index with Luke (v. 1.0.1) but I can't see any document's content. What I can see with Luke is the correct index size (800 documents) and the correct fields. But I can't put new documents in it, remove existing documents or see the content of existing documents.
The server is a linux server (I think it's debian) and apache is running on it. On my local machine I'm using PHP 5.3.1, the server uses PHP 5.2.9.
I also tried it now on a Windows machine with wamp server (and PHP version 5.2.11) and there it also works.
Do you have any idea, why it doesn't work on the server?

Posts: 28
Joined: Fri Oct 22, 2010 6:44 am

Re: Zend_Search_Lucene can't read index

Post by mmmshuddup » Sat Nov 27, 2010 12:39 pm

I'm having a similar issue.. A bit different because when I open navigate to my index folder via Luke it shows me nothing. I can't see any documents or anything. Yet the index creation process didn't throw any errors. I can't believe there isn't more software out there for reading Lucene indices...you'd think there would be if it is, after all, what Zend chose for their primary search classes. Not sure if it's possible, but Zend should consider adding a prettyPrint() function (like the Zend_Json one) or some sort of debug() function to this class so we can easily check it without even having to deal with some random app like Luke.

Posts: 1
Joined: Wed Jan 19, 2011 12:47 am

Re: Zend_Search_Lucene can't read index

Post by alxsss » Wed Jan 19, 2011 1:21 am


Is there anyway to know which version of lucene zend search libs use for indexing?


Post Reply