Failure to AutoStart Zend Server on i

General discussion on Zend Server for IBM System i
Post Reply
sodonnell
Posts: 9
Joined: Wed Jun 10, 2009 8:49 pm

Failure to AutoStart Zend Server on i

Post by sodonnell » Fri Mar 18, 2011 8:06 pm

Hi,

I need to autostart the Zend server on iSeries.

I have tried to use the menu option on the ZCMENU Admin menu named: Add restart ZC_STR_PRN job to scheduler
That adds a job who command is this:

CALL PGM(Zendcore/ZCPRNGCTRL)


The problem is that when this command runs, it errors out because it cannot find the prngd.pid file.

Instead it throws this error:

Object not found. Object is /usr/local/zend/core/logs/prngd.pid.


Can someone tell me how to either create the prngd.pid file (and what to put in it) or another way to auto-start the Zend server?

Thank you!

aseiden
Posts: 875
Joined: Thu Apr 09, 2009 5:45 pm

Re: Failure to AutoStart Zend Server on i

Post by aseiden » Fri Mar 18, 2011 10:39 pm

Hi, sodonnell,

Zend Server has a different menu than Zend Core did. If you're just coming up to speed on Zend Server, check out this link for a list of the basic operational differences between Core and Server:
http://www.alanseiden.com/2010/04/21/di ... -on-ibm-i/

I start the subsystem and web server in two steps:

Code: Select all

STRSBS SBSD(ZENDSVR) 
STRTCPSVR SERVER(*HTTP) HTTPSVR(ZENDSVR)
As for autostarting though a menu option, I don't know. Anyone know how to do that?

Alan

zend_i5
Posts: 158
Joined: Mon Mar 23, 2009 5:22 pm

Re: Failure to AutoStart Zend Server on i

Post by zend_i5 » Sat Mar 19, 2011 11:16 pm

Run following commands:
1. addlible zendsvr and Enter
2. ZSAUTOJOB and F4
3. Set Prngd daemon to Y

erich_hieden
Posts: 393
Joined: Tue Jul 07, 2009 9:01 am

Re: Failure to AutoStart Zend Server on i

Post by erich_hieden » Mon Mar 21, 2011 9:00 am

After doing a Zend Server installation, the ZENDSVR subsystem is automatically started from QSYSWRK subsystem. Though the ZENDSVR HTTP-Instance can happen to not get started at system startup, depending on your system settings. Using CHGHTTPA you can check if your system starts HTTP server instances at STRTCP automatically. For each HTTP server instance you can define if it should use this global value or should always or never be started at STRTCP, using the HTTP Admin instance at http://<server-ip>:2001/HTTPAdmin (maybe you need to start this instance manually using STRTCPSVR SERVER(*HTTP) HTTPSVR(*ADMIN)).

Regards

christiand_serti_com
Posts: 31
Joined: Wed Mar 25, 2009 12:57 am

Re: Failure to AutoStart Zend Server on i

Post by christiand_serti_com » Tue Mar 22, 2011 12:34 pm

zend_i5 wrote:Run following commands:
1. addlible zendsvr and Enter
2. ZSAUTOJOB and F4
3. Set Prngd daemon to Y
Can you elaborate on what this does exactly ? what's Prngd ?

aaron-s-hawley
Posts: 46
Joined: Thu Mar 11, 2010 4:43 pm
Location: Colchester, VT
Contact:

Re: Failure to AutoStart Zend Server on i

Post by aaron-s-hawley » Tue Mar 22, 2011 2:18 pm

christiand_serti_com wrote:Can you elaborate on what this does exactly ? what's Prngd ?
That's an answer to why PRNGD is not starting in Zend Server. You're asking how to get Zend Core to automatically start in the Zend Server forum. I think you'll need to use Erich's instructions but use the Zend Core equivalents.

PRNGD is the pseudo-random number generator daemon. The menu item "Add restart ZC_STR_PRN job to scheduler" was a false lead to getting Zend Core to "Autostart".

erich_hieden
Posts: 393
Joined: Tue Jul 07, 2009 9:01 am

Re: Failure to AutoStart Zend Server on i

Post by erich_hieden » Tue Mar 22, 2011 8:25 pm

Sorry for not reading precisely. Haven't seen that you were asking for ZendCore. Well my answer is nevertheless the same. Just replace ZENDSVR by ZENDCORE.

Or do yourself a favor and install ZendServer and don't mess with ZendCore anymore.

Regards

Post Reply