ZMAIL Extension in 6.01 (PHP 5.4) missing?

General discussion on Zend Server for IBM System i
kennethlwaston
Posts: 7
Joined: Mon Aug 24, 2009 3:40 pm

ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by kennethlwaston » Mon Apr 15, 2013 6:31 pm

I just installed ZendServer 6.01 over the weekend and I thought everything was fine until I discovered email was not working using the PHP command mail().

I switched back to version 5.04 and email is working again.

I noticed that the ZMAIL extension is missing in the 6.01 release (or not visible in the extensions).

The ZMAIL extension in 5.04 says "A PHP extension that implements an SMTP client. In IBM i it takes overs php's mail() function and handles all calls to this function."

Has anyone else experienced this? Any suggestions?

kennethlwaston
Posts: 7
Joined: Mon Aug 24, 2009 3:40 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by kennethlwaston » Tue Apr 16, 2013 9:22 pm

Wanted to correct my post.

My previous version of ZendServer was 5.5.0 (PHP 5.3.8) not 5.04.

bill_westbury_putnam
Posts: 7
Joined: Tue Dec 21, 2010 8:52 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by bill_westbury_putnam » Wed Apr 17, 2013 7:22 pm

Same issue here. Mail not working for V6.0.1. Will have to stay with V5 here until someone can explain the issue.

User avatar
rodflohr
Zend Global Support
Posts: 56
Joined: Mon Dec 29, 2008 5:28 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by rodflohr » Mon May 20, 2013 7:20 am

Zend R&D has confirmed this is an issue for PHP 5.4, and is working on a fix. Zend Server 6.0.1 for PHP 5.3 should not have the issue.

kennethlwaston
Posts: 7
Joined: Mon Aug 24, 2009 3:40 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by kennethlwaston » Mon May 20, 2013 3:03 pm

Thank you for the update.

I will be watching for a fix.

bill_westbury_putnam
Posts: 7
Joined: Tue Dec 21, 2010 8:52 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by bill_westbury_putnam » Tue Aug 27, 2013 2:49 pm

This is still not working in Zend 6.1 for PHP 5.4 (at least not for me).

kennethlwaston
Posts: 7
Joined: Mon Aug 24, 2009 3:40 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by kennethlwaston » Tue Aug 27, 2013 3:05 pm

I applied the 6.1 (5.4) update and it fixed the problem for me. Mail now works.

bill_westbury_putnam
Posts: 7
Joined: Tue Dec 21, 2010 8:52 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by bill_westbury_putnam » Tue Aug 27, 2013 3:13 pm

Interesting. I just applied the 6.1 update from 6.0.1 ptf and tried a batch script (php-cli) and it still didn't work, but I'll keep fooling with it. Thanks for letting me know it should be working.

geor2937
Posts: 2
Joined: Tue Sep 03, 2013 6:07 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by geor2937 » Tue Sep 03, 2013 6:09 pm

Same issue here. Just upgraded from ZendServer 5.0.1 to 6.1 with PHP 5.4 and now email no longer works. Going to have to switch back to the old version until there is a fix for this.

geor2937
Posts: 2
Joined: Tue Sep 03, 2013 6:07 pm

Re: ZMAIL Extension in 6.01 (PHP 5.4) missing?

Post by geor2937 » Wed Sep 04, 2013 3:38 pm

Some additional info. I've got the SMTP settings in PHP.INI pointing to the correct email server but according to the log when the mail function runs, it is attempting to connect to the IP address associated with localhost rather than the email address of the mail server.

Post Reply