Convert CCSID 65535 to ASCII

General discussion on Zend Server for IBM System i
Post Reply
Posts: 7
Joined: Wed Jun 24, 2015 4:31 pm

Convert CCSID 65535 to ASCII

Post by patr9257 » Wed Jun 24, 2015 4:40 pm

We have just installed Zend Server 8 on our IBM i (AS/400). I am running a test php script over one of the physical files (PF) in our ERP system. Several of the fields in the PF are defined as CCSID(65535). If I try to query over fields that are not CCSID 65535, my query works just fine. If, however, I run the query in my php script over fields defined as CCSID(65535), it will not display any results. I checked my system value QCCSID and it is set to 65535. Is there a way to set up the Zend Apache Server to convert CCSID 65535 without having to change QCCSID? I looked in the KB and found article "Set CCSID and Language options for FastCGI and Apache on the IBM i". I did what was recommended in the article but it did not work. Any advice? Thanks.

Posts: 187
Joined: Wed Apr 22, 2009 2:29 pm
Location: Edmonton, AB, Canada

Re: Convert CCSID 65535 to ASCII

Post by scottgcampbell » Thu Jun 25, 2015 7:00 pm

Try the suggestions here

And see if any of those work. If not post what you have tried and what kind of results you are getting.


Post Reply