Page 1 of 1

performance issue

Posted: Tue Oct 25, 2016 9:23 am
by alex8579
Hello guys,

we have a small issue with a zend server installation.
we had severals installations with no issues, but now i am stucked :(

i don't know how to describe it but the performance is very bad.
Even the Zendserver dashboard is very slow (response time > 1 minute).
No i have no clue how to solve this issue?

Current setup is:
IBM i --> V7R2M0
ZendServer developer standard --> Zend-Server-8.5

thanks for any replay,
alex

Re: performance issue

Posted: Tue Oct 25, 2016 2:32 pm
by alex8579
fyi:
when i call a php script by the browser it takes about 30 seconds.
when i call the same script via qsh it takes about 3 seconds...

Re: performance issue

Posted: Wed Dec 07, 2016 9:59 am
by sam3047
The problem could be in the network connection to partition in question. Check TCP receive buffer size and TCP send buffer size using TCP/IP Attributes command (CHGTCPA). It should be setup to at list 32000K

Re: performance issue

Posted: Wed Dec 21, 2016 2:19 am
by strysd
Hello, sam3047.
According to the following page, the maximum of receive and send buffer size is 8388608, it is equal to 8192K bytes and 8M bytes.

Do you mean 3200K bytes?
Thank You.

Re: performance issue

Posted: Sat Jan 14, 2017 5:08 am
by strysd
Usually, it is recommended to set the buffer size based on bandwidth and RTT.

If the bandwidth is 1Gbps and RTT is 10ms, buffer needs about 1.2M bytes.
(1 *1000*1000*1000)bit * 0.01second / 8 = 1250000 bytes

RTT can be shown by ping command from your client PC to Zend Server.

Thank You.

Re: performance issue

Posted: Fri Jan 27, 2017 8:17 am
by strysd
And I recommend checking firstly SendBufferSize in httpd.conf , before checking the buffer size in CHGTCPA .
Because CHGTCPA affects all users in IBM i.
If the SendBufferSize is not set, default value is zero, it means Apache uses size defined in OS (by CHGTCPA) .

Thank You.