Zend Server 9 (MariaDB 10) innodb_buffer_pool_size

General discussion on Zend Server for IBM System i

Zend Server 9 (MariaDB 10) innodb_buffer_pool_size

Postby gile2186 on Mon May 22, 2017 1:07 pm

I cannot seem to make innodb_buffer_pool_size larger than 496M.

I know it's influenced by other parameters like innodb_buffer_pool_instances but no matter what I set these to I cannot get innodb_buffer_pool_size to go above 496M.

I have created a new partition and get the same error on that as well.

The error that I receive is:

2017-05-18 14:40:55 1 [Note] InnoDB: Initializing buffer pool, size = 498.0M
InnoDB: mmap(552075264 bytes) failed; errno 12
2017-05-18 14:40:55 1 InnoDB: Assertion failure in thread 1 in file mem0dbg . cc line 680
InnoDB: Failing assertion: heap->magic_n == MEM_BLOCK_MAGIC_N.

I am ending ZENDDBI10 before I make the change and deleting the ib_logfile's before restarting ZENDDBI10.

It appears to point to being out of memory but I have ended MySQL/Zend Server 8 (which runs with innodb_buffer_pool_size set at 1200M) and still get the same error when starting MariaDB on its own.
gile2186
 
Posts: 3
Joined: Wed Apr 19, 2017 9:40 am

Return to Zend Server for IBM i

Who is online

Users browsing this forum: No registered users and 1 guest

cron