zend_jobqueue.enable_http

General discussion on Zend Server for IBM System i
Post Reply
thomasmatthes
Posts: 20
Joined: Thu May 26, 2011 12:29 pm

zend_jobqueue.enable_http

Post by thomasmatthes » Wed Dec 13, 2017 1:03 pm

Dear Zend-Support Team,

throughout the last year we have set up an SSL-certificate for our server (80.156.221.162:10081). Ever since we have problems with the exceution of our deposited the scripts/cronjobs.

Excecuting the script-files using the direct URL path works perfectly for HTTP and HTTPS.
But excecuting the exact same path using the zend server cronjobs (HTTP) this did and does not work anymore. Looking at configuration (Admin: Configurations > Components) we got the following error message: "Failed to create job rule: HTTPS jobs are not supported" (compare: https_error.PNG) --> see attachment_1
Attachment_1.png
Attachment_1.png (38.93 KiB) Viewed 914 times
Therefore we enabled HTTPS (zend_jobqueue.enable_https -> on) settings for the cronjobs and recognized the following note: "Enable support for HTTPS jobs (experimental)" (compare: ssl_cron_on.PNG) Is this feature not supported or guaranteed to work? --> see attachment_2
Atttachment_2.png
Atttachment_2.png (85.93 KiB) Viewed 914 times
Well, the excecution of the cronjobs, as mentioned still does not work. The cronjobs are executed but the status just says: "Failed" (compare: https_cron_failed.PNG). Regarding the server's log-files the error message (for HTTPS) is: "... Job xyz failed. Bad HTTP response" (compare: cron_logs.PNG), compared to older cronjobs the using HTTP the message was: "... Job xyz failed. Bad HTTP response 301" --> see attachment_3
Attachment_3.png
Attachment_3.png (123.09 KiB) Viewed 914 times
So as mentioned, after our latest testings (regarding HTTPS) we again obtained no positive results. Checking the log-files we got the following error-messages:

[JobQueue 08.11.2017 13:40:00 p205880/t1 WARNING] Job 526832 failed. Bad HTTP response


Since the configuration of the zend server was adjusted to HTTPS, the error message looks like a bug or misconfiguration of the zend server itself. And since this error message does not help us continuing to fix the problem we could only access the cronjobs from another server at this point, I therefore ask you for support.

Thanks in advance for your feedback.

thomasmatthes
Posts: 20
Joined: Thu May 26, 2011 12:29 pm

Re: zend_jobqueue.enable_http

Post by thomasmatthes » Wed Mar 21, 2018 11:02 am

No ideas?

Post Reply