Page 1 of 1

i5_connect failing

Posted: Mon Dec 18, 2017 8:31 pm
by kris6674
Hi,

Can somebody help me on the below issue.

Our PHP code is using i5_connect to connect to Iseries server to run certain command and its failing.

We are still on Zendserver 5 using community version. recently upgraded our Iseries version to V7R2.

That was working fine before the OS upgrade but failing after OS upgrade.

I tried the following things:
1. go zendsvr/zstmenu

2. Then selected option 1. Start PHP Toolkit service
Library . . . . . . . . . . . . > ZENDSVR
i5_COMD Service Port number . . 6079
Enable Prestart Jobs . . . . . . *OFF
Restart i5_COMD if running . . . *NO

3. when i check the joblog , it gives an error
EASYCOMD not running, port=6079: A remote host refused an attempted
connect operation.

we are going to upgrade the zend to latest licensed version in 2018 first quarter.
So we need some temporary fix for this till then.
Any help to resolve this is highly appreciated.

Thanks
Krishna

Re: i5_connect failing

Posted: Thu Jan 11, 2018 6:07 pm
by dura8336
I have the same problem!

Re: i5_connect failing

Posted: Thu Feb 15, 2018 5:52 pm
by alan8630
This is the problem to same peoples.

Re: i5_connect failing

Posted: Sun Feb 18, 2018 7:46 am
by sam3047
It looks like Easycom requires license after OS upgrade. Check QSYSOPER message queue

Re: i5_connect failing

Posted: Sat Mar 03, 2018 1:05 pm
by marc5457
I have the same problem!

Re: i5_connect failing

Posted: Tue Mar 06, 2018 8:42 pm
by sidn7670
I have the same problem!

Re: i5_connect failing

Posted: Wed Mar 14, 2018 4:15 pm
by manu2132
It looks like Easycom requires license after OS upgrade. Check QSYSOPER message queue

Re: i5_connect failing

Posted: Wed Apr 18, 2018 8:51 pm
by cris3641
It does not seem like a very difficult problem to solve.