ZS5.6 reports out as 5.1?

General discussion on Zend Server for IBM System i
jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

ZS5.6 reports out as 5.1?

Post by jjcllhn » Tue Dec 27, 2011 9:25 pm

Just downloaded and installed ZendServer 5.6 on an IBM 1 running 5.4, replacing ZS 5.1.

After restarting the server, it's reporting itself out as 5.1 from the Console (Monitor>Server Info):
Zend Server
Version 5.1.0

PHP
Version 5.3.8-ZS5.5.0

PHP Configuration File /usr/local/ZendSvr/etc/php.ini
Here's what it looks like on the IBM i.
Display Installed Licensed Programs
System: S103WR9M
Licensed Installed
Program Status Description
1DEVEXR *INSTALLED AS/400 Device Exerciser
1MAXAVA *INSTALLED Maxava Data Replication Licensed Product
2ZSVRPI *INSTALLED Zend Server for IBM i 5.6.0 ( PHP 5.3 )
No obvious failures from glancing through the install joblog, seems to be working correctly and have the expected new functions, various files in the appropriate IFS directories indicate that they were updated. Is there a small bug in the reporting mechanism, or do I need to re-install?

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Tue Dec 27, 2011 10:02 pm

Never mind- seems the /usr/local/zendsvr/gui restores failed silently throwing CPD3779.

Directories /usr/local/zendsvr/gui,/usr/local/zendsvr/etc, and /usr/local/zendsvr/var are owned by QTMHHTTP.

Trying to restore them when saved with ownerid QSECOFR requires changes to the object ownership, or a change to the RST ALWOBJDIF parameter.

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Wed Dec 28, 2011 9:34 pm

Still reporting out as Zend Server 5.1.1 rather than 5.6.

Performed clean installs (uninstalled licensed program, removed all orphaned IFS objects associated with ZS and MySQL, run install to successful completion) using both Windows install and IBMi SAVF.

erich_hieden
Posts: 393
Joined: Tue Jul 07, 2009 9:01 am

Re: ZS5.6 reports out as 5.1?

Post by erich_hieden » Thu Dec 29, 2011 7:19 am

No problem over here using the PHP 5.2 variant of ZendServer 5.6.0 (PTF install)

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Thu Dec 29, 2011 5:30 pm

Thanks for the response, Eric. Maybe there's a bug in the ZS5.6 with php 5.3 release package? Everything seems to be installed and running. I'm seeing some of the expected 5.6 changes (PHP 5.3.8, ZF 1.11.10, references to App deployment, MySQL 5.1.50...) but there's also 5.1 material (reporting out at 5.1.1., Help still at 5.1, ... ). Well out of the initial silver support period, just poking about to see what's changed for the better.

Also struggling with MySQL 5.1.50 lower_case_table_names.

Was expecting the default behavior to change per the YiPs wiki
Version 5.1.50 of DB2 Storage Engine implemented a new default UPPER case behavior change. ZendDBi installed into case insensitive directory (/usr/local) will now force UPPER case instead of “lower” case to avoid double quotes incompatible with legacy databases and applications. UPPER case will be the default for DB2 Storage Engine from now forward.
Still getting translated to "lower" from both phpMyAdmin and CLI, even when schema and table names are entered as all uppercase and less than 10 characters.

zend_i5
Posts: 158
Joined: Mon Mar 23, 2009 5:22 pm

Re: ZS5.6 reports out as 5.1?

Post by zend_i5 » Fri Dec 30, 2011 8:56 am

1. Regarding the 5.1 help. Try to clear the browser cache before requesting the GUI help in 5.6
2. Regarding the updated DB2i storage. The updated module is located in the /usr/local/zendsvr/bin folder. The Release Notes include the detailed update instructions.

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Fri Dec 30, 2011 5:00 pm

Thanks for the pointing out the extra instructions. The IBMDB2I storage engine is working as expected after copying the new plugin per the instructions.

Still showing 5.1 help, and reporting out as ZS 5.1.1 from the console. DSPSAVF header QGPL/ZSVRSAVF for both the Windows and manual install:

Code: Select all

                              Display Save Header               
                                                                
 Save file  . . . . . . . . . . . . . . :   ZSVRSAVF            
   Library  . . . . . . . . . . . . . . :     QGPL              
   Records  . . . . . . . . . . . . . . :     1640569           
 Save operation:                                                
   Save command . . . . . . . . . . . . :   SAVLICPGM           
   Save date/time . . . . . . . . . . . :   12/14/11  10:53:58  
   Save while active  . . . . . . . . . :   *NO                 
   Data compressed  . . . . . . . . . . :   Yes                 
   Release level  . . . . . . . . . . . :   V5R4M0              
 Data saved:                                                    
   Library  . . . . . . . . . . . . . . :   QTEMP               
   ASP  . . . . . . . . . . . . . . . . :   1                   
   System serial number . . . . . . . . :   06-63764            
                                                                

User avatar
shlomov
Zend Global Support
Posts: 139
Joined: Mon Dec 29, 2008 2:38 pm

Re: ZS5.6 reports out as 5.1?

Post by shlomov » Thu Jan 05, 2012 10:44 am

We have identified an issue with an upgrade from V5.0.x to 5.1 and than to 5.6. (LODPTF LICPGM(2ZSVRPI))
(i.e. -> you had Zend Server 5.0.x and used a PTF to upgrade to V5.1 and than PTF upgrade to V5.6)
We will issue a new PTF to correct the problem.

Version 5.1.0 is the last version that is shipped with the "i5 Toolkit extension" and it is no longer available for download, if you are using the i5 Toolkit extension in your php scripts than it will be best to wait for the fixed PTF.
else
if not used, than you are welcome to download the complete Zend Server V5.6.0 product SAVF and reinstall.
DLTLICPGM and RSTLICPGM
Shlomo Vanunu
IBM System i

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Thu Jan 05, 2012 3:30 pm

shlomov wrote:if not used, than you are welcome to download the complete Zend Server V5.6.0 product SAVF and reinstall.
DLTLICPGM and RSTLICPGM
If you read my posts above, you'll note that I've run through the DLTLICPGM/RSTLICPGM cycle twice trying to install ZS5.6 with php5.3- once using the Windows install, once using the SAVF install from the command line. Ran both installs as QSECOFR. Cleared out associated IFS objects that are installed but not deleted by DLTLICPGM both times (i.e., MySQL, /etc/my.cnf ). Still end up with ZS reporting itself as 5.1.1 from the controller.

Either there are additional objects that need to be deleted after DLTLICPGM (and aren't being reported as not being updated/overwritten as part of the install), the current ZS5.6 w php 5.3 save file doesn't contain 5.6 and needs to be rebuilt, or there's some other consideration (ZS CE doesn't report out as 5.6? Only reports out as 5.6 after CE license is entered?).

I'll be happy to supply additional info, but I've already spent more time installing ZS5.6 than planned.

jjcllhn
Posts: 34
Joined: Tue May 05, 2009 7:15 pm

Re: ZS5.6 reports out as 5.1?

Post by jjcllhn » Fri Jan 06, 2012 10:19 pm

Could the problem be the values in /usr/local/zendsvr/gui/application/data/zend-server.ini ? Modified stamp of this IFS file is 7/6/2011 6:08PM (all the other zend-server*.ini files in this directory are stamped 11/28/2011 2:44PM ). Can anyone verify this is the source of the value displayed on the web admin console, and/or that the value is stored as 5.6.0 with the ZS5.6 with php5.2 version?

Can this value be modified despite the message? Are there other stale values in this file that are/could impact the installed ZS instance?

File contents:

Code: Select all

; DO NOT EDIT THIS FILE
; This is a file generated by Zend Server installation.
  
[zendServer]
version = 5.1.1
build = ZEND_SERVER_GUI_6_0_32_20110405
packageBuild = INSTALLATION_PLACEHOLDER_PACKAGE_BUILD_NUMBER
isNode = 0
pagingSize = 20
logVerbosity = ERR
xmlBeautify="0"

[apiKeys]

[userServer]
url = INSTALLATION_PLACEHOLDER_USER_SERVER_URL

[monitor]
logfile=logfiles.xml
logfileRefreshInterval = 5
phpMyAdminUrl = /phpmyadmin
displayWelcome = 1

[updates]
updateXmlUrl = http://www.zend.com/news/server-updates/feed
lastViewed=""
feedsCount=10

[dateFormats]
short="d-M-Y"
medium="d-M H:i"
long="d-M-Y H:i"

[authentication]
password = INSTALLATION_PLACEHOLDER_GUI_PASSWORD

[registration]
acceptedTerms = "0"
newsletterEmail = ""
completed = "0"

[studioIntegration]
studioDetectBrowser=1
studioHost= 
studioPort=10137
studioUseSsl=0
alternateDebugServer=
studioAutoDetectionEnabled=1
studioAutoDetection=1
studioAutoDetectionPort=20080

Post Reply