zenddbi error

General discussion on Zend Server for IBM System i
Post Reply
Posts: 21
Joined: Thu Mar 26, 2009 11:59 am

zenddbi error

Post by amcusack » Tue Feb 28, 2012 6:28 am

Has anyone been able to get the zendbdi technology preview to work ?

I can't get the savf to save correctly to my system.

I have tried 3 methods :-
1) my usual method, bug busters install aid (automated ftp) which has always been successful in the past
2) manual ftp as per the docs

in each case I get the following error

Code: Select all

MSGID      TYPE                    SEV  DATE      TIME             FROM PGM     LIBRARY     INST     TO PGM      LIBRARY     INST
CPF5175    Escape                  40   28/02/12  15:07:30.044133  QSRFMERR     QSYS        004C     QTMFCOM2    QTCP        *STMT
                                     From user . . . . . . . . . :   TONYC
                                     To module . . . . . . . . . :   QTMFFXFR
                                     To procedure  . . . . . . . :   WrtRecData__FPci
                                     Statement . . . . . . . . . :   198          *PRCLT
                                     Message . . . . :   Incorrect record for output operation to save file.
                                     Cause . . . . . :   An incorrect record was output to save file ZENDDBI in
                                       QGPL. The condition code is 1. Condition codes and their meanings follow: 1
                                       -- A record is out of sequence.  The data you are trying to write into the
                                       save file may not be from a save file; 2 -- The data in a record was
                                       modified since it was retrieved from a save file or the record is part of a
                                       different save than the records that are already in the file; 3 -- The data
                                       in a record is from a save on a newer version of the system, that is not
                                       compatible with this version. Recovery  . . . :   You can use the DSPFD
                                       command to determine how many records are now in the save file.  Try the
                                       request again with the correct record data.
I have downloaded it twice with the same result. (Zip file is 112,887,232 bytes, SAVF is 462,038,016 bytes, zip archive passes test in winzip)

So, is the download corrupt or can anyone offer any suggestions as to what the problem might be ?


Tony C

Posts: 3
Joined: Tue Feb 16, 2010 10:17 pm

Re: zenddbi error

Post by davidbferguson » Thu Mar 01, 2012 10:57 pm

I just downloaded ZendDBi 5.1.59 and received the same error when I attempted a cpyfrmstmf.

I also got a windows error when I changed the name of the file from zenddbi.savf to ZENDDBI.FILE and attempted to drag and drop it into qsys.lib/qgpl.lib (this worked without any problems for the Zend Server save file, cumulative PTF save file and the hotfix save file).

Posts: 21
Joined: Thu Mar 26, 2009 11:59 am

Re: zenddbi error

Post by amcusack » Fri Mar 02, 2012 2:04 am

Thanks David, I guess that means the file made available for download is the problem. We'll just have to wait for a new version.


Tony C

Posts: 6
Joined: Thu Feb 11, 2010 10:35 am

Re: zenddbi error

Post by mbiffi » Fri Mar 02, 2012 10:12 am

I have the same problem.

I downloaded today the file zenddbi on my linux client and tried to upload the file on my IBM i in manual ftp as described in the docs:
230 $USERFTP logged on.
Remote system type is .
ftp> bin
200 Representation type is binary IMAGE.
ftp> cd qgpl
250 "QGPL" is current library.
ftp> put zenddbi.savf ZENDDBI
local: zenddbi.savf remote: ZENDDBI
200 PORT subcommand request successful.
150 Sending file to member ZENDDBI in file ZENDDBI in library QGPL.
netout: Broken pipe
426-Cannot write to member ZENDDBI in file ZENDDBI in library QGPL.
426 Data transfer ended.
ftp> quit
221 QUIT subcommand received.

I have recreated the save file on IBM i, downloaded the zenddbi again and retried to upload the file from a windows pc with the same problem.

I think the Zend site file is really corrupted.

Posts: 71
Joined: Fri May 01, 2009 8:19 pm

Re: zenddbi error

Post by timclark2000 » Fri Mar 02, 2012 10:42 pm

Did you create the save file with CRTSAVF FILE(QGPL/ZENDDBI), first?

The installation instructions are garbled and thus misleading:
1. Log on to the IBM i system with QSECOFR user profile.
a. Stop the Zend Server subsystem using the following Zend Server setup menu options:
But you do need to be sure that you create an empty save file before you ftp into it from your PC.

Posts: 158
Joined: Mon Mar 23, 2009 5:22 pm

Re: zenddbi error

Post by zend_i5 » Tue Mar 06, 2012 4:52 pm

The ZendDBi installation file is replaced and is available for download

Posts: 71
Joined: Fri May 01, 2009 8:19 pm

Re: zenddbi error

Post by timclark2000 » Tue Mar 06, 2012 4:58 pm

It looks like the ReadMe at http://static.zend.com/topics/DBi-readme.txt is still garbled or missing content. Step 1a that I quoted above doesn't make sense. It looks like a couple of lines are missing.

Post Reply