ZEND for ibm istop working

General discussion on Zend Server for IBM System i
Post Reply
amilcarmorales
Posts: 1
Joined: Mon Aug 20, 2012 9:10 pm

ZEND for ibm istop working

Post by amilcarmorales » Tue Aug 21, 2012 6:04 pm

Since two months ago, we have been working fine with ZEND Server for ibm i installed on a V5R4 iSeries.
Suddenly it stop working and each time we invoke the execution of our old .php files, it tries to download the source code instead.
Amilcar

kent_zacharias
Posts: 22
Joined: Mon May 09, 2011 8:05 pm

Re: ZEND for ibm istop working

Post by kent_zacharias » Tue Aug 21, 2012 6:42 pm

Hello amilcarmorales,

I have been running Zend on version 5.4 for over a year now with no errors as you have described.

Use the WRKACTJOB (work active job command) and verify Zend is running. For example:

Zend server:

Opt Subsystem/Job User Type CPU % Function Status
QHTTPSVR QSYS SBS .0 DEQW
ZENDSVR QTMHHTTP BCH .0 PGM-QZHBMAIN SIGW
ZENDSVR QTMHHTTP BCI .0 PGM-QZSRLOG SIGW
ZENDSVR QTMHHTTP BCI .0 PGM-QZSRLOG SIGW
ZENDSVR QTMHHTTP BCI .0 PGM-QZSRHTTP SIGW
ZENDSVR QTMHHTTP BCI .0 PGM-zfcgi SELW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi THDW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi TIMW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi TIMW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi TIMW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi TIMW
ZENDSVR QTMHHTTP BCI .0 PGM-php-cgi.bi TIMW

Zend server Java objects:

ZENDSVR QSYS SBS .0 DEQW
I5_COMD QTCP BCH .0 PGM-EASYCOMD TIMW
ZSJAVA_BRG QTMHHTTP BCI .0 PGM-watchdog THDW
ZSJAVA_BRG QTMHHTTP BCI .0 JVM-com.zend.j SELW
ZSJOBQMNG QTMHHTTP BCI .0 PGM-watchdog THDW
ZSJOBQMNG QTMHHTTP BCI .0 PGM-jqd SELW
ZSMONMNG QTMHHTTP BCI .0 PGM-watchdog THDW
ZSMONMNG QTMHHTTP BCI .0 PGM-MonitorNod SELW

MySQL Daemon is up and running.

ZMYSQL QSYS SBS .0 DEQW
ZMYSQLD MYSQL BCI .0 PGM-mysqld SELW

from the command file : go zendsvr/zsmenu to display the Zend Server for IBM i Setup Menu to manually start/stop.

aseiden
Posts: 877
Joined: Thu Apr 09, 2009 5:45 pm

Re: ZEND for ibm istop working

Post by aseiden » Tue Aug 21, 2012 7:02 pm

I agree that stopping/restarting the Zend subsystem and ZENDSVR web servers are the best first step.

After that, did something happen to your Apache configuration? Apache should recognize .php files as PHP and run them using FastCgi. Something may be wrong with your Apache config.

Alan

Post Reply