ZSCM deployment problems on AWS

General discussion forum for the Zend Server

ZSCM deployment problems on AWS

Postby auterium on Tue Nov 13, 2012 5:33 pm

It's beeing quite some time since I've wanted to have the oportunity to get my hands on ZSCM and full-featured ZS and when I saw this was available on AWS Marketplace I just though "Awesome!!", but it had turned out the complete opposite.

I wanted to use first the licensed version of Zend Server, but it turned out it won't have a license by it's own, it needs a ZSCM, which must also be in a different instance (although ZSCM has no cost for this).

So, if I have the AMI with Zend Server without linking it to a ZSCM, I can do deployments without problem, but I won't have all the features enabled.

If I link the ZS to ZSCM and try to deploy my zpk file, I can upload it without problem, but when it gets to select the display name & virtual host, I click next and get the following error:
Zend Deployment database error: SQLSTATE[HY000]: General error: 1 no such table: deployment_tasks_descriptors

I've tried with several instances, updating all software on both ZS and ZSCM and still no change on the error.

Any advice is much appreciated.

Thanks in advance
auterium
 
Posts: 2
Joined: Tue Nov 13, 2012 5:26 pm

Re: ZSCM deployment problems on AWS

Postby auterium on Wed Nov 14, 2012 7:57 pm

So, since I'm kind of impacient and the SLA for gold support won't reply instantly, I decided to dig up by myself on this.

It turned out that sqlite database for the deployments was empty: no tables in it.

So I found out the script that creates them, used it, and re-created the .db file with the proper tables. Now the deployments work as a charm!!

About an hour later I got response from support saying that I shouldn't be using the 5.5 instances, but the 5.6 ones.

Hope this helps anybody that gets into this kind of problems.
auterium
 
Posts: 2
Joined: Tue Nov 13, 2012 5:26 pm

Re: ZSCM deployment problems on AWS

Postby kentatzend on Wed Nov 14, 2012 11:38 pm

The configuration of the AMIs on Marketplace are set up to be used in a clustered environment. In that environment MySQL is used for the DB not SQLlite. So that is why the tables were not set up. It wasn't intended to be used in this way but I'm glad you got it working.
User avatar
kentatzend
 
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm


Return to Zend Server

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests