Issue with imagick module

General discussion forum for the Zend Server

Issue with imagick module

Postby dgriessinger on Thu Oct 25, 2012 1:57 pm

Dear all,

I have a very simple code:

Code: Select all
<?php
$svg=<<<EOF
<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" >
<svg version="1.1" height="300px" width="300px">
  <circle cx="100" cy="50" r="40" stroke="black" stroke-width="2" fill="red" />
</svg>
EOF;

$im=new Imagick();
$im->readImageBlob($svg);
$im->setImageFormat('png');

header('Content-type: image/png');
echo $im;
?>


When I try to run it, I get on log

Uncaught exception 'ImagickException' with message 'UnableToOpenBlob `/tmp/magick-XXwGVxDK': Aucun fichier ou dossier de ce type'
I use Zend Server 5.6 on Linux, same result with Zend Server 6.0 beta.
But it's working with ZS windows.

It seems that imagick cannot have sufficent rights to create temporary file !

If you have any idea, it will help me a lot

Thanks
Dams
dgriessinger
 
Posts: 1
Joined: Fri Sep 07, 2012 10:46 am

Re: Issue with imagick module

Postby zvika on Thu Nov 08, 2012 1:44 pm

Hi

I've tested this on 3 different systems, and indeed it seems from strace that there is a problem with permission or internal conflict (un-linking and then looking for the file).
I've opened a bug.
[EDIT] The bug is specifically related to temporary files, to manage parsing SVG data - I tried to generate a blob and read it and it worked fine - so a workaround can be to generate the blobs by calling imagemagic with exec().

Thanks for the report!

[UPDATE] This issue will be fixed in the next Zend Server version.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 780
Joined: Sun Dec 14, 2008 9:48 am


Return to Zend Server

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests