"FastCGI process exceeded configured activity timeout" error

General discussion forum for the Zend Server

"FastCGI process exceeded configured activity timeout" error

Postby jbeall on Thu Mar 26, 2009 3:57 pm

Hi All,

I'm using Zend Server on Windows XP Pro/IIS, and when I enter a debugging session, I get this error after 30 seconds:

Code: Select all
FastCGI Error
The FastCGI Handler was unable to process the request.

Error Details:

    * The FastCGI process exceeded configured activity timeout
    * Error Number: 258 (0x80070102).
    * Error Description: The wait operation timed out.

HTTP Error 500 - Server Error.
Internet Information Services (IIS)


After googling this I found that some people had success by updating %WINDIR%\system32\inetsrv\fcgiext.ini where it specifies the activity timeout. I edited that file and I've got this in there now:
Code: Select all
ActivityTimeout=300
; - Specifies the maximum time, in seconds, that a FastCGI process for this
;   application is allowed to run without communicating with IIS.  In practice,
;   this timeout is used to detect and shut down 'hung' processes.  If not
;   specified, the default value is 30 seconds.


But, after restarting IIS, I'm still getting the same behavior--after 30 seconds, the debugging session terminates and I get that error.

PHP is configured to timeout after 300 (not 30) seconds, so I don't think that's the issue either.

Any suggestions? It's really frustrating to try and fit my debugging sessions inside of 30 seconds! There *must* be a way to correct this.
jbeall
 
Posts: 72
Joined: Thu Jan 15, 2009 5:18 pm

Re: "FastCGI process exceeded configured activity timeout" error

Postby jbeall on Fri Mar 27, 2009 1:28 pm

Found the problem.

I just searched for "ActivityTimeout", noted that it was commented out and that it defaults to 30 seconds, then uncommented it, and set the value to "300".

I figured that would do it. Seems reasonable, right?

But in order for it to affect PHP, you have to scroll down to the bottom of the file and find this section, and ensure that ActivityTimeout is set in *this* block, like this:

Code: Select all
[Types]
php=PHP

[PHP]
ExePath=C:\Program Files\Zend\ZendServer\bin\php-cgi.exe
EnvironmentVars=PHPRC:C:\Program Files\Zend\ZendServer\etc,PHP_FCGI_MAX_REQUESTS:10000
ActivityTimeout=300


Once I did that, and restarted IIS, I was able to debug just fine (for 300 seconds, anyway).
jbeall
 
Posts: 72
Joined: Thu Jan 15, 2009 5:18 pm

Re: "FastCGI process exceeded configured activity timeout" error

Postby pkskyzend on Fri Mar 19, 2010 7:51 pm

This post helped me.

I might add that I think the reason uncommenting out the TimeoutActivity line in the commented section didn't was because the commented section is not meant to controlled that way, it is strictly a reference. I added the line as suggested in the last post without uncommenting anything and got the expected results of increasing the time out.
pkskyzend
 
Posts: 1
Joined: Fri Mar 19, 2010 7:40 pm

Re: "FastCGI process exceeded configured activity timeout" e

Postby userofit on Tue Nov 27, 2012 4:01 am

My fix is:
From IIS Web Application Basic Settings, set the Application pool to the same as with ZendServer.
userofit
 
Posts: 1
Joined: Tue Nov 27, 2012 3:59 am


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 8 guests