MongoDB disable(d) mongo.so

General discussion forum for the Zend Server

MongoDB disable(d) mongo.so

Postby freakingme on Mon Feb 25, 2013 12:54 am

Hi,

I just tried to install the mongodb package, but noticed that the MongoDB class still was not available to my php code. Turns out that even after installing the php-5.4-mongo-zend-server package, the extension is not enabled:

vagrant@houdini:~/tmp$ apt-get download php-5.4-mongo-zend-server
Get:1 Downloading php-5.4-mongo-zend-server 5.4.11+b1 [106 kB]
Fetched 106 kB in 0s (227 kB/s)

vagrant@houdini:~/tmp$ ar vx php-5.4-mongo-zend-server_5.4.11+b1_amd64.deb
x - debian-binary
x - control.tar.gz
x - data.tar.gz

vagrant@houdini:~/tmp$ tar xvf data.tar.gz
./
./usr/
./usr/local/
./usr/local/zend/
./usr/local/zend/lib/
./usr/local/zend/lib/php_extensions/
./usr/local/zend/lib/php_extensions/mongo.so
./usr/local/zend/etc/
./usr/local/zend/etc/conf.d/
./usr/local/zend/etc/conf.d/mongo.ini

vagrant@houdini:~/tmp$ cat ./usr/local/zend/etc/conf.d/mongo.ini
;extension=mongo.so
; You may put any extension-specific directives here


I had expected the module to be enabled in the mongo.ini file, instead; it wasn't.

I'm on ubuntu 12.04: Linux houdini.dev 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
freakingme
 
Posts: 6
Joined: Tue Nov 17, 2009 8:54 pm

Re: MongoDB disable(d) mongo.so

Postby zend_eyalt on Mon Feb 25, 2013 7:43 am

Hi,

We have indeed slightly changed the way packages are arranged in ZS6:

In ZS5.X, you wouldn't have mongo installed when installing Zend Server base package, and you would have indeed have been required to install that package separately - in which case it would come enabled (as you explicitly required the package).
In ZS6, we provide this extension (and other extensions that used to be part of the php-5.X-extra-extensions-zend-server) as part of the base package, but they come disabled by default as not to have tons of extensions enabled by default.

To enable the mongo extension (or any other disabled extension), simply go the the GUI's Configuration->PHP page, and enable the extension - you would also be required to restart your PHP environment (top right corner icon).
User avatar
zend_eyalt
 
Posts: 71
Joined: Thu Jan 22, 2009 3:16 pm


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 3 guests