failed to install zend-server on openSuse 12.3

General discussion forum for the Zend Server
Post Reply
ke3855
Posts: 2
Joined: Sun May 26, 2013 7:36 pm

failed to install zend-server on openSuse 12.3

Post by ke3855 » Sun May 26, 2013 7:45 pm

I encountered the libphp5 issues during the installation of zend-server 6.0.1 onto my openSuse12.3

I didn't install SELinux.

using script downloaded from zend to install in CLI

got following:
------------------------------------------------------------------------------
................
...................

(62/62) Installing: zend-server-php-5.4-6.0.1-515 .........................................[done]
Additional rpm output:
X-Powered-By: PHP/5.4.11 ZendServer/5.0
Content-type: text/html

X-Powered-By: PHP/5.4.11 ZendServer/5.0
Content-type: text/html

X-Powered-By: PHP/5.4.11 ZendServer/5.0
Content-type: text/html

Stopping Zend Server 6.0.1 ..

zsd is not running
jqd is not running
zdd is not running
scd is not running
lighttpd is not running
redirecting to systemctl stop
Shutting down httpd2 (not running)..done
monitor is not running

Zend Server stopped.
Creating/Upgrading Zend databases. This may take several minutes...
X-Powered-By: PHP/5.4.11 ZendServer/5.0
Content-type: text/html

Module "authz_default" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
httpd2-prefork: Syntax error on line 180 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: Syntax error on line 3 of /etc/apache2/conf.d/zendserver_php.conf: Cannot load /usr/local/zend/lib/apache2/libphp5..so into server: /usr/local/zend/lib/apache2/libphp5..so: undefined symbol: unixd_config
Zend Server Daemon: running service's main ...

X-Powered-By: PHP/5.4.11 ZendServer/5.0
Content-type: text/html

ERROR: "/usr/sbin/apache2ctl" -S 2>&1 returned with error
Starting Zend Server 6.0.1 ..

Starting Zend Server Monitor node [OK]
[27.05.2013 03:56:28 SYSTEM] watchdog for monitor is running.
[27.05.2013 03:56:28 SYSTEM] monitor is running.
redirecting to systemctl start
Module "authz_default" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
Starting httpd2 (prefork) httpd2-prefork: Syntax error on line 180 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: Syntax error on line 3 of /etc/apache2/conf.d/zendserver_php.conf: Cannot load /usr/local/zend/lib/apache2/libphp5 .so into server: /usr/local/zend/lib/apache2/libphp5..so: undefined symbol: unixd_config

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

..failedspawn-fcgi: child spawned successfully: PID: 25659
Starting Zend Server GUI [Lighttpd] [OK]
[27.05.2013 03:56:30 SYSTEM] watchdog for lighttpd is running.
[27.05.2013 03:56:30 SYSTEM] lighttpd is running.
Starting Session Clustering daemon [OK]
[27.05.2013 03:56:31 SYSTEM] watchdog for scd is running.
[27.05.2013 03:56:31 SYSTEM] scd is running.
Starting Deployment [OK]
[27.05.2013 03:56:32 SYSTEM] watchdog for zdd is running.
[27.05.2013 03:56:32 SYSTEM] zdd is running.
Starting JobQueue [OK]
[27.05.2013 03:56:33 SYSTEM] watchdog for jqd is running.
[27.05.2013 03:56:33 SYSTEM] jqd is running.
Starting ZendServerDaemon [OK]
[27.05.2013 03:56:34 SYSTEM] watchdog for zsd is running.
[27.05.2013 03:56:34 SYSTEM] zsd is running.

Zend Server started...

Note: This output shows SysV services only and does not include native
systemd services. SysV configuration data might be overridden by native
systemd configuration.

zend-server 0:off 1:off 2:on 3:on 4:on 5:on 6:off
chmod: cannot operate on dangling symlink '/usr/local/zend/var/log/access.log'
chmod: cannot operate on dangling symlink '/usr/local/zend/var/log/error.log'
warning: %post(zend-server-php-5.4-6.0.1-515.x86_64) scriptlet failed, exit status 1



*******************************************
* Zend Server was successfully installed. *
*******************************************
-----------------------------------------------------------------------------------------------------------

Does anyone have any ideas of how to solve this issues?

many thanks.

ke3855
Posts: 2
Joined: Sun May 26, 2013 7:36 pm

Re: failed to install zend-server on openSuse 12.3

Post by ke3855 » Sun May 26, 2013 8:26 pm

found some info, but I don't know how I can resolve:
Default Re: Apache 2.4 compilation fails with: undefined symbol: unixd_config

Quote Originally Posted by cPanelKurtN View Post
Hi yannisc,

Please provide more information. For example, the portion of both configuration files it's complaining about (line 40 of httpd.conf and line 9 of your php.conf).

Additionally, did you upgrade from 2.2 to 2.4 recently?
This is the first time I try to upgrade to 2.4. I'm currently on 2.2.

line 40 of httpd.conf loads php.conf and line 9 of php.conf says:

LoadModule php5_module modules/libphp5..so

Reply:
Default Re: Apache 2.4 compilation fails with: undefined symbol: unixd_config

The error you're seeing is due to the fact that Apache 2.4 renamed an internal data structure from unixd_config to ap_unixd_config that your version of PHP is still looking for (link here).

Can you copy and paste the profile you're using to build Apache 2.4? Feel free to use any one of the online pastebin like websites out there.

Kurt
Developer (EasyApache Team)
Cpanel, Inc.


User avatar
liorkaplan
Posts: 108
Joined: Tue Jun 22, 2010 5:59 am

Re: failed to install zend-server on openSuse 12.3

Post by liorkaplan » Mon May 27, 2013 9:28 am

ke3855 wrote:I encountered the libphp5 issues during the installation of zend-server 6.0.1 onto my openSuse12.3
Hi,

It indeed looks like Apache 2.4, which isn't supported at the moment.

Please verify with "rpm -qa | grep apache" or "rpm -qa | grep httpd"

Post Reply