Page 4 of 7

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Tue Sep 01, 2009 10:26 pm
by smithdg
This is the exact error message:

Code: Select all

090901 16:20:46 mysqld_safe Starting mysqld daemon with databases from /usr/local/zend/mysql/data
090901 16:20:46 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/zend/mysql/data/ is case insensitive
/usr/local/zend/mysql/bin/mysqld: Table 'mysql.plugin' doesn't exist
090901 16:20:46 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
InnoDB: Log scan progressed past the checkpoint lsn 0 39548
090901 16:20:46  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 0 46409
090901 16:20:46  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 
InnoDB: Apply batch completed
090901 16:20:47  InnoDB: Started; log sequence number 0 46409
090901 16:20:47 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
090901 16:20:47 mysqld_safe mysqld from pid file /usr/local/zend/mysql/data/ratbert.omrf.hsc.net.ou.edu.pid ended

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Wed Sep 02, 2009 9:11 pm
by urkman
Hello,

I can't start apache in Snow Leopard. I get this error:
[Wed Sep 02 22:08:49 2009] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
httpd(2602,0xa0695500) malloc: *** error for object 0xbfffe778: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Greetings,
Urkman

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Wed Sep 02, 2009 11:43 pm
by jess04
Hello,

This is a different [and new] issue.
May I have ssh access to this machine so I can look into it?
Regardless of yes or no, feel free to drop me a line at jess zend com so we can investigate further.

Thanks,

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Thu Sep 03, 2009 12:41 pm
by urkman
Hello,
jess04 wrote: May I have ssh access to this machine so I can look into it?
Regardless of yes or no, feel free to drop me a line at jess zend com so we can investigate further.
I think we can do it over the Weekend. But perhaps I can give you some system information, just tell me what you need.

Greetings,
Urkman

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Mon Sep 07, 2009 3:07 pm
by urkman
Hello,

are there any news about ZendServer and Snow Leopard?

Thanks and Greetings,
Urkman

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Mon Sep 07, 2009 3:17 pm
by jess04
Hello,

ZS 4.0.6 will include a fix for the WD issue.
Meanwhile, you can use the modified zendctl.sh attached to one of the posts in this thread.

Thank you,

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Mon Sep 07, 2009 3:21 pm
by urkman
Hello,
jess04 wrote: ZS 4.0.6 will include a fix for the WD issue.
Any Date for that?
jess04 wrote: Meanwhile, you can use the modified zendctl.sh attached to one of the posts in this thread.
This was not working for me, so I'm back to 10.5 for the Moment:
viewtopic.php?f=44&t=1115&p=8256#p8066

Greetings,
Urkman

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Mon Sep 07, 2009 5:02 pm
by joshbutts
Zend Folks:

Any update on this?

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Tue Sep 08, 2009 3:12 pm
by jess04
Hello all,

Attached is a fix for the watchdog.
Please replace /usr/local/zend/bin/watchdog binary with this one.

Thank you all for reporting and testing.
Your feedback is most wanted.

Re: Zend Server CE and Mac OS X 10.6 (Snow Leopard)

Posted: Tue Sep 08, 2009 3:21 pm
by panosru
Hello, Jess, thanks for the fix, I didn't tried it yet, before I try it I would like to ask if we need to replace the lighttpdctl.sh you provided earlier with the default one.
EDIT:
I replaced the lighttpdctl.sh you provided with the original and stoped / start the Zend Server, seems to running well :)

Thanks for the fix Jess, your support is really valuable!

Here is the output of the terminal:
bash-3.2# ./zendctl.sh stop
Stopping ZendServer 4.0.5 ..

/usr/local/zend/bin/apachectl stop [OK]
lighttpd is not running
Shutting down MySQL
. SUCCESS!
Stopping Java bridge [OK]

ZendServer stopped.
bash-3.2# ./zendctl.sh start
Starting ZendServer 4.0.5 ..

/usr/local/zend/bin/apachectl start [OK]
spawn-fcgi: child spawned successfully: PID: 28655
Starting ZendServer GUI [Lighttpd] [OK]
[ 08.09.2009 17:24:52 SYSTEM] watchdog for lighttpd is running.
[ 08.09.2009 17:24:52 SYSTEM] lighttpd is not running.
Starting MySQL
. SUCCESS!
Starting Java bridge [OK]
[ 08.09.2009 17:24:53 SYSTEM] watchdog for java_daemon is running.
[ 08.09.2009 17:24:53 SYSTEM] java_daemon is running.

ZendServer started...
bash-3.2#