Page 1 of 1

Warning: The extension is not loaded

PostPosted: Mon Dec 15, 2014 4:35 pm
by fáb8522
Hi.

After I updated my MacOS 10.10 to the MacOS 10.10.1, I saw that my local website wasn't opening correctly anymore. So I went to the Zend Server Admin Panel, and I noticed that all the php extensions inside of the Zend Server >> Configuration >> PHP panel were in orange, with a warning saying that they were not loaded.

Ex.: Warning: The extension 'bcmath' is not loaded.

So after a couple hours, I fixed it by uninstalled Zend Server 7, removed all files and references to MySQL and PHP, cleaned it up really good, and installed the Zend Server 8 Beta. All those orange labels were gone, and my local website started to loaded correctly again. (Btw, I am using a ZS Developer's edition).

However, that fix only lasted one or two days. Then, out of the blue, it started to give me the same errors I got with ZS7.

Important notes:
1) I was using the Zend Server 7 for a few months now and it always worked fine.
2) I don't usually turn of the computer, but only put it so sleep.
3) I didn't perform any software or system update during those two days that the ZS was fixed.
4) Now that it is broken again, since the extensions are not loading, I can get the Z-ray to show up.
5) The website seems to load in parts, but apparently it breaks because of the missing extensions.
6) I noticed that some of the Configuration >> Components items are also giving the warning message.

My questions are:
1) How to fix it so it doesn't break again?
2) Why it worked fine for a couple days and then out of the sudden it broke?

Re: Warning: The extension is not loaded

PostPosted: Mon Dec 15, 2014 8:17 pm
by zvika
Hi

I have a feeling that multiple PHP executibles / Apache modules are involved (you got MAMPED?)

Please check phpinfo() output (or the server info in the overview section),
and verify that PHP is using the correct Configuration File (see what is loaded, include dir etc.)

Then, check what appears in PHP error log when you restart PHP (and if restart PHP resolves the modules loading problem).

Let me know what you find out.

BTW - Did you open a support ticket reporting the issue already? I would highly recommend that since this community support forum doesn't come with SLA...

Re: Warning: The extension is not loaded

PostPosted: Mon Dec 15, 2014 8:40 pm
by fáb8522
Hi,

Thanks for your reply.

Yes, I had opened a support ticket.

So, I restarted the server, and the PHP Error Log are basically composed with this statement:

[15-Dec-2014 14:19:06 America/Atikokan] PHP Notice: Undefined variable: zem_extension_info in /usr/local/zend/share/UserServer/zsd_print_extensions.php on line 6

I looked into my php_info and it seems fine. File attached.

Re: Warning: The extension is not loaded

PostPosted: Mon Dec 15, 2014 10:33 pm
by zvika
Hi
Do you have disk space outage on the drive?
Can you spot any empty (zero size) ini files under /usr/local/zend/etc ( and /conf.d ) ?

Thanks for opening a support ticket. Please make sure support tool is run on your Mac and attached to the ticket to have configuration and logs for review.

Thanks

Re: Warning: The extension is not loaded

PostPosted: Tue Aug 01, 2017 4:28 pm
by mist6499
Same issue. Any conclusion?