Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

General discussion forum for the Zend Server
mark9311
Posts: 4
Joined: Fri Oct 02, 2015 1:04 am

Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by mark9311 » Mon Oct 05, 2015 9:26 pm

Can we have an update on when a version supporting El Capitan will be released? Serious drag to not be able to develop locally on my MacBook Pro.

Thanks

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Server 8.5 update for OS X 10.11?

Post by alex6477 » Tue Oct 06, 2015 1:13 pm

No reaction from Zend, pitful reaction Zend!

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5 update for OS X 10.11?

Post by zvika » Wed Oct 07, 2015 7:55 am

Guys,
Just a general comment about response times - this is a community forum without SLA.

- for official support, with SLA for licensed products, you should create a support request at support.zend.com.

FYI,
we have found breaking issues with Zend Server 8.5.1 on 10.11 "El Capitan",
and we're currently working to provide more information and towards working Zend Server setup.
Zvika Dror
Zend Support Team

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Server 8.5 update for OS X 10.11?

Post by alex6477 » Wed Oct 07, 2015 9:56 am

Hey Zvika,

thank you for your reply.
I mean with pitful reaction the support too, sorry not the support the company because the support is only the messenger of bad news.
But the statement of the support request:

Mac OSX El Capitan 10.11 is not compatible with Zend Server and Zend Studio., but there is a plan to have the compatibility in the future. There is no current information as to when nor what version of the software will be compatible.

and

"We apologize for the inconvenience.

There is no information available as to which version of Zend Server will be compatible with Mac OSX El Capitan 10.11, but if you stay tuned, we will announce when this will be supported."



is unsustainable.

Therefore I ask officially here in the forum and I got a little more information.

Please note, we have to paid for the product and Zend have a plenty of time to check and adapt the software with the OSX 10.11 Beta releases ...
and what happend , the new OS is released and Zend Server are not compatible , a product i have to paid for it!!!!


Thank you an i hope i get an feedback ,maybe with a rough timeplan e.g. "we work for support in november oder december"

Alex

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5 update for OS X 10.11?

Post by zvika » Wed Oct 07, 2015 10:13 am

Hi Alex,
Thanks for the feedback.
I understand and I'm not familiar with the response you quoted - we can message it better I agree.

Debating in the forums is not effective - we are working to find and fix the issues with latest ZS 8.5.1 on both PHP versions.

Since you are paying for a license please get the official information in a support ticket which also provides feedback about your own experience,
until we have further news or a special El-Capitan package.

I have completed a fresh install (after removing PHP 5.6 branch with the uninstall script and install PHP 5.5 branch to compare) and after fixing lighttpd.ini things seems to be working normally,
we are doing this on multiple machines and hitting different scenarios.

Updates will follow, I'll mark this topic as the main "El Capitan" upgrade ref so people will not open separate threads.
Zvika Dror
Zend Support Team

jon7892
Posts: 3
Joined: Wed Feb 19, 2014 5:16 pm

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by jon7892 » Wed Oct 07, 2015 11:27 am

Please treat this as urgent, we have production issues too now!

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by alex6477 » Wed Oct 07, 2015 1:40 pm

Hi Zvika,

thank you for the exact reply.

I am now in a dilemma, i use OSX 10.10 cause i have to code with Zend Server + Studio a project, other hand i need to upgrade to OSX 10.11 to code a other project, accurate i have to test it under 10.11!
The dilemma, i upgrade my system to 10.11, worse Case the Zend Bundle didn't run and Zend say: "We apologize for the inconvenience, but the version for 10.11 comes in Q1/2016 oder Q2/2016"

The only thing i need is, you say OK , Alex upgrade your system and we find in cooperation with the support und the developers a solution for you, or you say please wait to XX.XXXX around this date we have checked Update-Package.

Can you explain me your: "and after fixing lighttpd.ini things " [seems to be working normally], or should i upgrade then open a Support request and further information i get in the request?

i don't understand what do you recommend me.

Thank you

Best regard Alex

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Wed Oct 07, 2015 2:06 pm

Jon - we're handling this in top priority.
Alex - upgrading your OS is your decision, I've NEVER upgraded ANY OS in a rush (there are release notes, blogs about broken features and applications, and other user's experience, and there are already updates for OSX 10.11 I didn't even implement yet).

I upgraded from 10.9 to 10.11 and installed ZS 8.5.1 in a clean setup (deleted /etc/zce* and completed /usr/local/zend/bin/uninstall.sh --automatic, then made sure 'ps aux | grep zend' doesn't show any leftover processes).
then I fixed /usr/local/zend/gui/lighttpd/etc/lighttpd.conf by uncommenting all the commented directives under "fastcgi.server = " section,
restarted Lighttpd with /usr/local/zend/bin/zendctl.sh restart-lighttpd, went back to http://localhost:10081 and completed the launch process with "Development" mode (I assume 0.001% would install "Production" mode so I haven't tested this yet).

Once there, I could update all libraries and plugins from the gallery, deployed the demo app and there are no "bad" entries in any of our logs.

Now, opening a support ticket will help to focus our efforts on any scenario which is NOT the above.

a KB will follow, but comments are welcome here (technical with errors, 1-2-3 steps etc)

P.S. - I didn't install Zend Studio yet on OS X 10.11, this is for another forum if problematic...
Zvika Dror
Zend Support Team

mark9311
Posts: 4
Joined: Fri Oct 02, 2015 1:04 am

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by mark9311 » Thu Oct 08, 2015 12:36 am

Just put in a support ticket. Could not select a version of Zend Server higher than 7, a PHP version higher than 5.5, or Mac OS X 10.11, but I put that in the ticket body.

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Thu Oct 08, 2015 9:01 am

Thanks Mark - I've seen the ticket and responded,
I'm attaching the replacement lighttpd.conf for anyone who wishes to give it a hurl until we release an official update on the downloads page.
Attachments
lighttpd-conf.zip
Replacement and Original versions of lighttpd.conf - Restart Lighttpd after replacing it.
(8.12 KiB) Downloaded 236 times
Zvika Dror
Zend Support Team

Post Reply