Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

General discussion forum for the Zend Server
alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Server 8.5.1 on OS X 10.11 "El Capitan"

Post by alex6477 » Thu Oct 08, 2015 1:03 pm

Hi Zvika,

thank your for your help, the workaround seems to run.
In the first step did'nt upgrade my live-system, i install a virtual machine with 10.11 and the i check Zend.

As i said before, it seems to run, only 1 issue i get: Offline daemon ; The daemon is offline

Next problem, i know you said : Studio is another building site and another thread, please let me explain:

I had install Zend Studio 13 without an error, it starts an the Studio said:

Local Zend Server has been detected and can be added to the list of PHP servers. ....

Press "OK" to enable Web API and to add the server, ...


I press "OK" an the he ask me for the "Zend Server Credentials" , admin + Password.
I fill the Password-Box and it don't accept my password ... my password works fine in the Zend Server Adminpage ...
if i want to add the Zend Server manually in the config, i get the same issue.

My question, is that an Zend Server-issue or an Zend Studio-issue? Do you test ur Zend Server- installation with an Studio?

Thank you for your help

Best regards Alex

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Thu Oct 08, 2015 2:26 pm

Hi Alex

Great news!
We will be releasing an update to Zend Server for El Capitan, hopefully early next week (but if we fail auto and sanity testing, it would delay until stable).

The second issue is a combined issue but the client is Zend Studio so you should open a ticket on Zend Studio.
There can be few bottlenecks on the way but since Studio has its flow which is not known to Server guys (like me),
it should be tackled by Studio experts and if needed - they ask Server guys (like... ok me!)

Daemon offline can be a temporary issue, since the status is in SQLite DBs and they can get locks or something else (simple or creepy),
so you can check the status (zendctl.sh status) and logs (tail -f /usr/local/zend/var/logs/*) and see what comes up.

Hope this helps.
Zvika Dror
Zend Support Team

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by alex6477 » Thu Oct 08, 2015 2:49 pm

Hi Zvika,

Really good news, do you (Zend) release only Zend Server or Zend Studio too around next week?

Thank you for your efforts and dedication.
i will check the status, and let you know about the results.

The problem with Studio i open an Studio-Case.

Thank you!

Best regards Alex

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Thu Oct 08, 2015 3:21 pm

Thanks Alex

Studio team is checking into the new OS X, I am not aware of their efforts or build status, but you can feel free to raise the topic in the Studio forum.
Zvika Dror
Zend Support Team

mark9311
Posts: 4
Joined: Fri Oct 02, 2015 1:04 am

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by mark9311 » Thu Oct 08, 2015 8:47 pm

Thank you Zvika.Now I know to submit a ticket for prompt and helpful response. Server 8.5.1 is working on OS X 10.11 for me now. For some reason just updating the lighttpd.conf file was not sufficient, but a full uninstall and reinstall of Zend server with the modified lighttpd.conf file got everything sorted. I had upgraded in place from 8.0 to 8.5 so I am not sure if there could have been an issue there.

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Fri Oct 09, 2015 3:10 pm

Good news Mark.
Reinstalling might have gone through launch again, which was broken initially. if you remove gui.db, IIRC, you get a new launch which can possibly remedy the situation.

The upgrade flow from 8.0 to 8.5 was tested on OS X 10.10, so no one actually knows what happens on OS X 10.11 since we started testing on recent package to answer the critical problem of people starting to update their Macs - in a development ENV its almost worth nothing if you do have your older setup or configuration - you can even drop parts of /etc or dump the configuration and load it back to new version if its important. Usually developers just use out of the box setup with some minor changes they already know by heart (after setting date.timezone properly, that is ;)
Zvika Dror
Zend Support Team

andr1834
Posts: 1
Joined: Mon Oct 12, 2015 3:25 pm

Re: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by andr1834 » Mon Oct 12, 2015 3:26 pm

The replacement lighthttpd.conf worked for me - thanks a lot.

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Tue Oct 13, 2015 4:46 pm

Hello Alex,
I've bumped into the problem of local Zend Server autodetect with Studio 13 and created a KB on how to clear an offending target to re-detect Server, properly:
https://support.zend.com/hc/en-us/articles/211862338

More good news
We have updated packages for El Pachino (sorry, had to have a laugh there) - El Capitano 10.11,
if you need to reinstall / fresh install - please head out to the Zend Server downloads page for the fresh packages.
http://www.zend.com/en/products/server/downloads

For any new problem with Zend Server 8.5.1+ and OS X 10.11 - please open a support ticket with our system.
Zvika Dror
Zend Support Team

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by alex6477 » Wed Oct 14, 2015 10:58 am

Hi Zvika,

i can only repeat it, very good work, Thank you for your dedication and patience.
particularly for the workaround and KB article for the Studio issuse!

Support ticket ... okay ... try to understand me:

before i posted here, i open a support ticket:

The reply and statement: "i don't know if and when"

You reply One Day later (07.10.15) in the forum an workaround after my post! GREAT!

In Contrast: Support Ticket: Good news Alex, we have an Update for Server (13.10.15) round about 1 Week later.
Good work, but the Server problem was solved 1 week ago by Zvika.
Actually i have an problem with the Zend Studio.

The same: Friday (09.10.) i posted the problem, monday (12.10.) i get the workaround, 1 day later you posted an KB article , great!

In Contrast: Support Ticket: i reply , its okay ,i get the solution in the forum.

IMHO the better way: forum thread?

thanks again Zvika, really good work!!!!


Greets Alex

PS: great joke , but my thunderstorm from the sky was also not bad? (in the studio thread)

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Solved: Zend Server 8.5.1 on OS X 10.11 "El Capital"

Post by zvika » Wed Oct 14, 2015 4:36 pm

Thanks Alex
Actually I started collecting support tickets form individual customers which cannot be pulled into single thread (actually, not a bad idea),
so summing and getting back to all required more time with waiting for the developers and packaging.
But support ticket gets to the team, whereas forum topics might be neglected since there is not always enough time to answer (moderation and answering+research are 2 completely different matters).

Enjoy!
Zvika Dror
Zend Support Team

Post Reply