"Manage Server" tab and manual php.ini edition

General discussion forum for the Zend Server
Post Reply
liam3446
Posts: 6
Joined: Mon Jun 20, 2016 3:52 pm

"Manage Server" tab and manual php.ini edition

Post by liam3446 » Mon Jun 20, 2016 5:06 pm

Hi !

I am new to Zend Server. I've been using manual installation of Apache and PHP so far. After installing of Zend Server I edited httpd.conf and php.ini manually as I always do. Then I went to "Servers" => "Manage Servers" (at http://localhost:10081/ZendServer) and it indicated "Server is in Warning state" and below many lines like "The directive 'xxx' is mismatched: expeted 'yyy', actual 'zzz' . I had to click kind of "Apply" button and then restart Zend Server. What is the mechanism behind this? I want to understand this, it looks like another layer on Apache. Why can't I just manually edit these config files? Is there any other way suggested to do this instead of manual edition ? Thanks.

User avatar
zend_eyalt
Posts: 282
Joined: Thu Jan 22, 2009 3:16 pm

Re: "Manage Server" tab and manual php.ini edition

Post by zend_eyalt » Wed Jun 22, 2016 9:22 am

Hi,

Here's first at all a link about Zend Server Architecture which might help a bit.

In general when changing a PHP runtime directive, the recommended way in Zend Server is to do so from the PHP->Extensions Page and set it there (you can directly search for the directive or part if its name in the search box). Setting the directive in this way ensures it is updated both in the Zend Server blueprint and the File System. This becomes even more important when dealing with a cluster where you want all File Systems to be updated.

Now, when you directly change a directive value in the File System, Zend Server will indeed complain about mismatch between File System and Blueprint, and then you need to resolve the mismatch as to align the two.

liam3446
Posts: 6
Joined: Mon Jun 20, 2016 3:52 pm

Re: "Manage Server" tab and manual php.ini edition

Post by liam3446 » Thu Jun 23, 2016 2:37 pm

Thank you. This was helpful !

Post Reply