https URL not working in recurring job

General discussion forum for the Zend Server

https URL not working in recurring job

Postby stanny on Mon Jul 11, 2016 12:42 pm

Hi

I have created a Zend Sever Recurring Job with a URL of

https://www.xxxx-xxxx.co.uk/admin/searc ... nerate-csv

and get FAILED in the Job Queue -> Jobs report with the Output tab reporting "You're speaking plain HTTP to an SSL-enabled server port" as shown below.

The createHttpJob in the prepareGenerateCsvAction uses the https version of the URL also. Even when I add an exit before any HTTP job is created the job still fails.

The code works perfectly using a plain http URL. I can't see anywhere in the settings to specify SSL or port numbers so am a bit lost!



HTTP/1.1 400 Bad Request

Date: Mon, 11 Jul 2016 11:31:47 GMT

Server: Apache/2.4.7 (Ubuntu)

Content-Length: 447

Connection: close

Content-Type: text/html; charset=iso-8859-1



<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

<html><head>

<title>400 Bad Request</title>

</head><body>

<h1>Bad Request</h1>

<p>Your browser sent a request that this server could not understand.<br />

Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />

Instead use the HTTPS scheme to access this URL, please.<br />

</p>

<hr>

<address>Apache/2.4.7 (Ubuntu) Server at http://www.xxxx-xxxx.co.uk Port 443</address>

</body></html>
stanny
 
Posts: 3
Joined: Mon Aug 23, 2010 9:42 pm

Re: https URL not working in recurring job [solved]

Postby stanny on Mon Jul 11, 2016 1:52 pm

I have got it working now. The problem is that I edited a job originally created on the insecure URL. When creating the job it must look at the URL and auto choose the application to use. Changing the URL does not change the application so you need to create a new job to change the application.
stanny
 
Posts: 3
Joined: Mon Aug 23, 2010 9:42 pm

Re: https URL not working in recurring job

Postby zend_eyalt on Tue Jul 12, 2016 10:57 am

Hi there,

Thank you for taking the time of both posting the question and providing the workaround you found.

Indeed you have discovered a bug in Zend Server which we hope will make it to one of the forth coming maintenance releases.

Regards,
Eyal
User avatar
zend_eyalt
 
Posts: 251
Joined: Thu Jan 22, 2009 3:16 pm

Re: https URL not working in recurring job

Postby zend_eyalt on Mon Oct 10, 2016 9:32 am

Happy to update that ZS 9.0.1 is available for download, and the bug described here should be fixed.

You can grab the LINUX download from:
http://www.zend.com/en/products/server/downloads#Linux%20(x86_64)%20
User avatar
zend_eyalt
 
Posts: 251
Joined: Thu Jan 22, 2009 3:16 pm


Return to Zend Server

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests