Update on long-term support for Zend Server and PHP 5.x

General discussion forum for the Zend Server

Update on long-term support for Zend Server and PHP 5.x

Postby MickeyZend on Sun Aug 07, 2016 3:05 pm

By now, we're sure that you've heard of PHP 7. This groundbreaking version, released last November, provides unprecedented performance gains, typically resulting in doubled throughput and dramatically reduced memory consumption. We're proud of the leadership role Zend played in spearheading the refactoring effort that led to these amazing gains, and we're overwhelmed by the response of the community.

We recognize that many of you may not be able to upgrade to PHP 7 just yet and could use some extra time to upgrade. Therefore, we’ve decided to extend Zend Server’s long-term support for PHP 5.6 all the way through the end of 2020, giving you 4.5 years to upgrade to PHP on your own terms.

To allow us to focus on the longest possible support timeline for PHP 5.6, and given the minor changes from PHP 5.5 and excellent compatibility track record of these two versions, we will no longer provide long-term support for PHP 5.5. We encourage all PHP 5 users to upgrade to PHP 5.6.

For further information, visit the Zend Server long-term support timeline.
User avatar
MickeyZend
Zend Product Manager
 
Posts: 95
Joined: Mon Aug 19, 2013 1:34 pm
Location: Israel

Re: Update on long-term support for Zend Server and PHP 5.x

Postby amar9450 on Fri Sep 16, 2016 5:59 am

This is a great news for every zend developers.i appreciate this post.
amar9450
 
Posts: 11
Joined: Wed Aug 03, 2016 6:02 am
Location: USA

Re: Update on long-term support for Zend Server and PHP 5.x

Postby bobbywires on Tue Nov 01, 2016 12:26 am

I am going through the preliminary planning of moving to a new iSeries server and have been running the 5.6.0 since 2012 with great results.
Two questions; Will a basic PHP7 be available to the iSeries at no charge and will it be possible to run PHP5.3 concurrently with PHP7 for migration and testing?
bobbywires
 
Posts: 32
Joined: Thu Jun 07, 2012 11:47 pm

Re: Update on long-term support for Zend Server and PHP 5.x

Postby MickeyZend on Thu Nov 03, 2016 1:05 pm

Hi bobbywires,

Currently the basic edition for IBMi is free (though limited to one year of support), regardless of the PHP version. That said, I cannot say this will not change sometime in the future.
You should be able to run both PHPs on the same LPAR. As I mentioned in another post, we have a Zend Server 9.0.1 for IBMi beta for those who are interested in participating and I know some said they would be using the side by side capability.

Good luck in migrating!

Mickey.
User avatar
MickeyZend
Zend Product Manager
 
Posts: 95
Joined: Mon Aug 19, 2013 1:34 pm
Location: Israel


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 5 guests