Database Locked when finishing set up

General discussion forum for the Zend Server

Database Locked when finishing set up

Postby rube3691 on Thu Jan 12, 2017 1:40 pm

I recently installed Zend Server Version: 9.0.1 Build: 108824 on a Linux Virtual machine using Ubuntu 14.04.1 LTS. I am using Apache2, and MySQL. After running the install script successfully, I accessed localhost:10081 (and 82) and followed the instructions on the screen. After pressing launch, it errors with the following message:
Code: Select all
Failed to set user details in bootstrap: Set Profile; Statement could not be executed (HY000 - 5 - database is locked)

I have tried restarting zend server multiple times. I have also attempted to reinstall it, reinstall the web server, rebooting the machine, deleting the zend database files (such as monitor, etc.).

I am at a loss as to how to solve the issue, and have not been capable of finding any information as to what might even be the issue.
rube3691
 
Posts: 2
Joined: Thu Jan 12, 2017 1:24 pm

Re: Database Locked when finishing set up

Postby zvika on Sun Jan 15, 2017 12:25 pm

Hi
First, try to do this wipe setup:
1. /usr/local/zend/bin/uninstall.sh
2. remove /usr/local/zend
3. remove user zend
4. remove Apache if you don't have any important settings, rename / remove /etc/apache2 and any leftover settings
5. apt-get update, apt-get autoremove, apt-get autoclean, apt-get install -f (probably will do nothing)
6. install Zend Server using the linux installer for ZS 9.0.1 (or apt-get install zend-server-php-7.0 for existing repo)
7. check http://127.0.0.1:10081 and initialize
8. if something is still not working, you can open a support ticket on support.zend.com, link back to this forum topic, and provide a support tool dump from /usr/local/zend/bin/support_tool.sh with the problem description, so we can assist with some offline facts.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Database Locked when finishing set up

Postby rube3691 on Mon Jan 23, 2017 7:04 pm

Thank you for your answer. Luckily, I was capable of solving the issue, though not through the method you described.

For posterity (and google searches): essentially, there was a conflict between my nagios3 install and the zend-server install. My guess is there was a conflict with the PHP version (IIRC nagios3 required php5), though why it manifested that way is beyond me. Regardless, after speaking with some colleagues who had also had the issue and told me this had been it, I was able to complete the set up.
rube3691
 
Posts: 2
Joined: Thu Jan 12, 2017 1:24 pm


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 6 guests