Install Zend Server in cPanel/WHM

General discussion forum for the Zend Server

Install Zend Server in cPanel/WHM

Postby tim7158 on Wed Jul 12, 2017 2:26 am

Hi,

The last post I saw on this topic was from 2011. I am having trouble installing Zend Server 8.5.7 on a CPanel/WHM machine (that has only my websites).

I get the error
Requires: httpd >= 2.2.0
But
httpd -v
Server version: Apache/2.4.25 (cPanel)

This is a CentOS installation. PHP 5.5

The relevant part that starts the problem chain reaction is:

--> Processing Dependency: php-5.5-fcgi-zend-server for package: zend-server-php-5.5-common-8.5.6-970.x86_64
--> Processing Dependency: php-5.5-pdo-mysql-zend-server for package: zend-server-php-5.5-common-8.5.6-970.x86_64
--> Finished Dependency Resolution
Error: Package: mod-php-5.5-apache2-zend-server-5.5.38-19.x86_64 (Zend)
Requires: httpd >= 2.2.0
Error: Package: zend-server-php-5.5-common-8.5.6-970.x86_64 (Zend)
Requires: php-5.5-extra-extensions-zend-server

Thank you as I am stuck.

Tim
tim7158
 
Posts: 1
Joined: Wed Jul 12, 2017 2:20 am

Re: Install Zend Server in cPanel/WHM

Postby zend_eyalt on Wed Jul 12, 2017 6:43 pm

While I'm not familiar with the hosting environment you're working with, it seems to me that the problem here is that you're trying to install Zend Server 8.5.7 on a PHP 5.5 environment, while Zend Server 8.5.7 is intended for PHP 5.6 only.
see the links below:
viewtopic.php?f=8&t=132128
http://www.zend.com/en/support-center/s ... rm-support

Any chance you might switch to php 5.6 ?
User avatar
zend_eyalt
 
Posts: 242
Joined: Thu Jan 22, 2009 3:16 pm


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 1 guest