oci_connect(): ORA-28547: connection to server failed...

General discussion forum for the Zend Server

oci_connect(): ORA-28547: connection to server failed...

Postby smallred-byu on Wed Sep 13, 2017 12:22 am

I'm currently trying to connect to an Oracle server running Oracle 12.x.

On my windows machine I am able to connect fine, but I am running Zend Server 9.x, which uses 12.1.x of the oracle client with PHP 7.x.

On my linux test machine, I get the ORA-28547 error, which is on Zend Server 8.x and runs the 11.1.x of the oracle client.

"oci_connect(): ORA-28547: connection to server failed, probable Oracle Net admin error"

I installed version 12.2 of the oracle instant client successfully, but can't figure out how to switch to the Red Hat installed version. I found a small blurb of text on the following page eluding to the fact that it should be possible to use a different client than the one shipped with Zend Server.

http://files.zend.com/help/Zend-Server/ ... onents.htm

"Zend Server provides the Oracle Instant Client 'Basic Lite' package, which only includes English error messages, and support for ASCII, Unicode and Western European character sets. If you need support for other languages and character sets, please install one of the other Oracle Instant Client packages available from Oracle, such as here:
http://www.oracle.com/technetwork/datab ... 97480.html.
You should be able to install any recent version of the full Oracle Instant Client libraries as a drop-in replacement for the Lite version provided by Zend, without having to reinstall Zend Server.
In Linux, make sure that you place the full version's shared libraries before the Lite version in 'LD_LIBRARY_PATH'."

Can someone provide instructions for switching the basic light driver that ships with Zend Server to the one I've installed? I'm hoping that will fix my ORA-28547 error.

Thanks

Shane
smallred-byu
 
Posts: 7
Joined: Fri Jan 13, 2012 7:00 pm

Re: oci_connect(): ORA-28547: connection to server failed...

Postby smallred-byu on Wed Sep 13, 2017 6:34 pm

For anyone else struggling with replacing the default oracle basic light client. I found a guide that helped me get Oracle working on Zend Server 8.X.

http://www.orware.com/blog/tips-and-how ... stallation

Once I created and replaced the oci8.so module, I just replaced the one found in /usr/local/zend/lib/php_extensions and restarted the server. Now everything works as it should.

P.S. If you are running PHP 5.6 the highest version of the OCI8 package you can use is 2.0.12. Any higher versions than this require PHP >= 7.

Thanks
smallred-byu
 
Posts: 7
Joined: Fri Jan 13, 2012 7:00 pm


Return to Zend Server

Who is online

Users browsing this forum: Google [Bot] and 5 guests