Zend server 9.1 and phpmyadmin issue

General discussion forum for the Zend Server
Post Reply
aman8944
Posts: 3
Joined: Fri Mar 09, 2018 11:23 am

Zend server 9.1 and phpmyadmin issue

Post by aman8944 » Fri Mar 09, 2018 12:51 pm

I have installed the trial version of Zend server 9.1 on window 7 (64 bit), following the instructions are given in the document. Also, I have deployed phpmyadmin app. Now If I hit http://localhost/phpmyadmin to open and see the database, I get the below-given error. Also attaching the screenshot of that error.

#2002 - No connection could be made because the target machine actively refused it.
— The server is not responding (or the local server's socket is not correctly configured).
mysqli_real_connect(): (HY000/2002): No connection could be made because the target machine actively refused it.


Can anybody suggest me what is wrong here and how can I resolve this?
Attachments
error.JPG
This is what I get when go for phpmyadmin
error.JPG (65.89 KiB) Viewed 957 times

User avatar
zend_eyalt
Posts: 270
Joined: Thu Jan 22, 2009 3:16 pm

Re: Zend server 9.1 and phpmyadmin issue

Post by zend_eyalt » Sat Mar 10, 2018 10:10 pm

googling this error, leads to an impression that perhaps there's a problem starting the MySQL service - did you install the bundled MySQL that comes with Zend Server ? Did you have by any chance another installation ?
Suggest you double check that the MySQL service is up and running and that the credentials you use are those conifgured in phpmyadmin, have perhaps a look at the following relevant articles:
https://stackoverflow.com/questions/167 ... t/40214597
https://w3guy.com/connection-controluse ... on-failed/
https://ourcodeworld.com/articles/read/ ... refused-it

aman8944
Posts: 3
Joined: Fri Mar 09, 2018 11:23 am

Re: Zend server 9.1 and phpmyadmin issue

Post by aman8944 » Wed May 23, 2018 12:57 pm

Thanks, Zend_eyalt,
Actually, I installed the MySQL that comes with Zend Server but somehow it was not installed properly. So I manually installed it and all is working fine now.

Post Reply