Page 1 of 2

zend server 2018 on ubuntu 18.04

Posted: Wed Jun 27, 2018 2:56 pm
by bert0901
Please advise if this is possible as done a quick test and had lots of dependencies missing and unable to install.

Would like to setup a new dev server and replace my existing 16.04 with 9.1 zend server.

Many thanks

Re: zend server 2018 on ubuntu 18.04

Posted: Mon Jul 09, 2018 7:26 am
by zend_eyalt
Zend Server 2018.0.0 does not yet support Ubuntu 18.04.
The next maintenance release, 2018.0.1 should support it so please wait before upgrading

Re: zend server 2018 on ubuntu 18.04

Posted: Sun Jul 22, 2018 10:38 am
by MickeyZend
Now available see announcement above.

Re: zend server 2018 on ubuntu 18.04

Posted: Sun Jul 29, 2018 12:36 pm
by bert0901
Many Thanks

Just installing now, all went okay. Except the plugins page giving error :

Failed to load resource: net::ERR_CERT_DATE_INVALID

So cannot get list of plugins available. Can get list on older zend server version.

Re: zend server 2018 on ubuntu 18.04

Posted: Thu Aug 02, 2018 9:36 am
by MickeyZend
I understand you're talking about the plugins in the Zend Server|Gallery. Right?
Please share - did you run an upgrade or installed from scratch? Did you run our one liner install script?

Thanks

Re: zend server 2018 on ubuntu 18.04

Posted: Fri Aug 17, 2018 10:44 am
by tlamedia
I just tried installing ZS 2018 on a fresh Ubuntu 18.04 and i got the following error:

The following packages have unmet dependencies:
zend-server-php-7.2-common : Depends: php-7.2-common-extensions-zend-server (>= 9.2.0) but it is not going to be installed
Depends: php-7.2-extra-extensions-zend-server but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Package zend-server-nginx-php-7.2 is not installed.
Package zend-server-php-7.2-common is not installed.

Re: zend server 2018 on ubuntu 18.04

Posted: Sun Aug 19, 2018 8:43 am
by liorkaplan
Which repository are you using ? Could you send the content of /etc/apt/sources.list.d/zend.list

Re: zend server 2018 on ubuntu 18.04

Posted: Mon Aug 20, 2018 9:43 am
by tlamedia

Re: zend server 2018 on ubuntu 18.04

Posted: Fri Aug 24, 2018 8:06 am
by tlamedia
Any help on this? I can't be the only one having this issue since it's a fresh and basic Ubuntu 18.04 install

Re: zend server 2018 on ubuntu 18.04

Posted: Mon Aug 27, 2018 8:15 am
by zvika
Hello tlamedia, bert0901,
we have triple checked that fresh Ubuntu 18.04 gets installed without any problems with Apache and NginX.

The problem seems to be "a dirty" machine with old packages / certificates, and the need to start clean.

My advice, if you still have the problem, would be to remove Zend Server (uninstall script in /usr/local/zend/bin),
remove the web server (purge all packages with configuration), clean APT (autoclean / autoremove / clean all),
then look for "zend" under /etc/apt/sources.d/ and sources.list and remove the references, update APT and you're ready to install.

To start clean, ignore the option to install Zend Server manually for this time,
download the latest Linux installer from the product page or your account / downloads, extract to /tmp and run (installs PHP as Apache module):
/tmp/ZendServer-RepositoryInstaller-linux/install_zs.sh 7.2 --automatic

or with your required options for FastCGI / NginX / more:
/tmp/ZendServer-RepositoryInstaller-linux/install_zs.sh 7.2 [nginx] [apache-fpm] --automatic
To get the complete list of command line options, run install_zs.sh without additional params.

If you have any failure or malfunction, please open a support case under support.roguewave.com -> Zend section, or log-in to your account and create a report from the Support menu.