Problems with ZendServer on Mac OSX Lion

General discussion forum for the Zend Server
urkman
Posts: 34
Joined: Thu Jan 15, 2009 9:15 am

Re: Problems with ZendServer on Mac OSX Lion

Post by urkman » Tue Jul 26, 2011 9:33 am

@kentatzend:
Sorry, but what you are saying is simply wrong.
1.) Lion Developer Previews are available since Februar this year, not only a few days...
2.) You are talking about "free software"... If you don't want to support "free software", then don't release it...

My suggestion:
Make ZendServer CE a paid product and support it correctly. We are using ZendServer, because we are working this our mac, not just playing with it...
So we are in need for a working version of our tools. And for me, ZendServer is the only software, that is not working with lion...

And this has nothing to do with early adopters, because we are not using any "beta software", just "stable software"...

Greetings,
Urkman

User avatar
kentatzend
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by kentatzend » Wed Jul 27, 2011 7:49 am

RE #1) When I say a few day I mean a few days since someone reported it ...not a few days since Lion. The problem apprears to be related to the Lion upgrade process as our QA people say it works fine on a clean install on Lion. But we're still looking into it a bit to see what we can do that might fix this.

RE#2) I didn't say I didn't want to support it (obviously we are looking into it. I was saying that that realistically non-pay product take priority behind pay products. I think everyone can understand that. I don't think I said anything about early adopters ... that was someone else.

As for making CE a pay product ... that's sort of not in the cards right now for a lot of reasons that would involve long and boring financial explanations that probably no one would care about anyway.

Kent

helektra
Posts: 1
Joined: Fri Jul 29, 2011 7:18 am

Re: Problems with ZendServer on Mac OSX Lion

Post by helektra » Fri Jul 29, 2011 7:47 am

Hi,
any news about zend server ce and lion incompatibility?
My old installation did not work after the lion update anymore.
I installed zend server again and at first it seems to work.
I tried to restart :
[gvmbp:/usr/local] gv% sudo /usr/local/zend/bin/zendctl.sh start
Starting ZendServer 5.1.0 ..

/usr/local/zend/bin/apachectl start [OK]
spawn-fcgi: socket is already in use, can't spawn
Starting ZendServer GUI [Lighttpd] [OK]
[ 28.07.2011 15:47:34 SYSTEM] watchdog for lighttpd is running.
[ 28.07.2011 15:47:34 SYSTEM] lighttpd is running.
Starting MySQL
. ERROR! Manager of pid-file quit without updating file.
Starting Java bridge [OK]
[ 28.07.2011 15:47:36 SYSTEM] watchdog for java_daemon is running.
[ 28.07.2011 15:47:36 SYSTEM] java_daemon is running.

ZendServer started...

When I look in the zend/tmp folder I can see that 2 files are marked with the lion incompatible icon:
java_daemon and lighttpd.
In the old and the new installation I could'nt get the mysql server to start.
Any hint?
Or is it better to switch back to the manual installation of apache, mysql and php?

Götz

orionit
Posts: 1
Joined: Fri Jul 29, 2011 7:29 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by orionit » Fri Jul 29, 2011 7:31 pm

I have isolated the problem. It has to do with the permissions on /usr/local/zend/gui/lighthttpd/logs/*.log files. For now, I have set these to be world-writeable (not good, but it works) and the zend server gui launches with no issues.

Hope this helps someone else and hope a proper fix from Zend is forthcoming.

marstonstudio
Posts: 20
Joined: Thu Sep 17, 2009 5:21 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by marstonstudio » Wed Aug 03, 2011 4:36 am

there are complainers and doers,

author of this blog post is a doer: http://www.worldgoneweb.com/2011/zend-s ... rmissions/

hugheba
Posts: 4
Joined: Thu Feb 25, 2010 9:09 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by hugheba » Wed Aug 03, 2011 8:00 pm

Anyone figure out why the built in phpMyAdmin give the error:
phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.
Looks like the session.save_path permissions might be messed up.

Can't seem to change the group back to "zend" from "smmsp" on the folders
/usr/local/zend/data
/usr/local/zend/tmp
/usr/local/zend/var

cmiwebstudio
Posts: 90
Joined: Mon Oct 26, 2009 1:38 am

Re: Problems with ZendServer on Mac OSX Lion

Post by cmiwebstudio » Thu Aug 04, 2011 6:37 am

?

urkman
Posts: 34
Joined: Thu Jan 15, 2009 9:15 am

Re: Problems with ZendServer on Mac OSX Lion

Post by urkman » Thu Aug 25, 2011 1:43 pm

More then one month gone... and still no update from zend...

Very very bad :(

User avatar
kentatzend
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by kentatzend » Thu Aug 25, 2011 5:27 pm

The problem is related to the Lion upgrade process removing a user from the system (specifically the Zend user that we created on the original install). Not sure why Apple thought that was a good idea but they did. So the simplest solution is to uninstall, then reinstall and then set the permissions to the zend user again.

New Lion installs work fine.

hugheba
Posts: 4
Joined: Thu Feb 25, 2010 9:09 pm

Re: Problems with ZendServer on Mac OSX Lion

Post by hugheba » Fri Aug 26, 2011 2:40 pm

kentatzend wrote:The problem is related to the Lion upgrade process removing a user from the system (specifically the Zend user that we created on the original install). Not sure why Apple thought that was a good idea but they did. So the simplest solution is to uninstall, then reinstall and then set the permissions to the zend user again.

New Lion installs work fine.
@kentatzend, when you say "set the permissions to the Zend user" after reinstall, do you mean chown -R the whole "/usr/local/zend directory"? Or are there varying permissions within that directory?

Post Reply