libxml trouble

General discussion forum for the Zend Server
Post Reply
jan_schumann
Posts: 2
Joined: Sat Mar 28, 2009 2:33 pm

libxml trouble

Post by jan_schumann » Sat Mar 28, 2009 2:38 pm

Hello.

I am having problems with libxml and libxslt.

After installing ZendServer, the following versions were active:

libxml
libXML support active
libXML Version 2.7.3
libXML streams enabled

xml
XML Support active
XML Namespace Support active
libxml2 Version 2.7.3

xsl
XSL enabled
Libxslt Version 1.1.23
libxslt compiled against libxml Version 2.6.32
EXSLT enabled
libexslt Version 1.1.23

Why is libxslt compiled against libxml Version 2.6.32 although libxml 2.7.3 is installed?

May this cause any issues. Because I have a segfault on

XSLTProcessor::transformToDoc

Any idea?

massi_zend
Posts: 15
Joined: Fri Jan 30, 2009 9:25 am

Re: libxml trouble

Post by massi_zend » Sat Mar 28, 2009 7:28 pm

Could you post the exact, yet as minimal as possible, code that generate the segfault so we can debug it?

BTW, what is the operative system the code is faulting?

Thanks in advance,
Massi.

jan_schumann
Posts: 2
Joined: Sat Mar 28, 2009 2:33 pm

Re: libxml trouble

Post by jan_schumann » Sat Apr 18, 2009 2:15 pm

Hi!

This configuration is now working for me!

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: libxml trouble

Post by jess04 » Sat Apr 18, 2009 11:42 pm

Hello,

We link statically against the libXML archive so it does not matter if the XSL extension was linked against an earlier version of the XML library [although the next version will be compiled against 2.7.3.

As Massi wrote, we need a code snippet to reproduce the issue with, also, can you please state your operating system and, if Linux, which distro?

Thanks,
May the source be with you,

Jess Portnoy

krav3n
Posts: 13
Joined: Wed Jun 24, 2009 7:49 pm

Re: libxml trouble

Post by krav3n » Mon Apr 26, 2010 4:04 pm

I had this same problem after upgrading to the latest version of zend server pe. I rebuilt the xsl module from source and am no longer having the problem.

Environment is ubuntu karmic x86 minimal. I get the segfault running propel:build-model under symfony 1.2.

Post Reply