SOLVED: changing port to 80 breaks zend backend on mac os x

General discussion forum for the Zend Server
Post Reply
smithdg
Posts: 41
Joined: Sun Mar 22, 2009 3:32 am

SOLVED: changing port to 80 breaks zend backend on mac os x

Post by smithdg » Mon Mar 30, 2009 8:48 pm

The install went great, and the first thing I did was go and change httpd.conf to listen to port 80 instead of 10088. Opened localhost, and all looked good, however then I couldn't get to the zend backend admin interface on port 10081. Is there another file I needed to edit?

thanks,
Danny
Last edited by smithdg on Thu Apr 02, 2009 5:32 am, edited 1 time in total.

massimilianoc
Posts: 699
Joined: Thu Mar 12, 2009 11:58 am

Re: changing port to 80 breaks zend backend on mac os x

Post by massimilianoc » Tue Mar 31, 2009 12:43 am

Try updating also file the directive 'url' under 'gui/application/data/zend-server.ini'.

Good luck,
Massi.
Best regards,
Massi.

smithdg
Posts: 41
Joined: Sun Mar 22, 2009 3:32 am

Re: changing port to 80 breaks zend backend on mac os x

Post by smithdg » Wed Apr 01, 2009 9:14 pm

massimilianoc wrote:Try updating also file the directive 'url' under 'gui/application/data/zend-server.ini'.

Good luck,
Massi.
I don't see that file. I am using the beta1, that is the latest right?

thanks,
Danny

massimilianoc
Posts: 699
Joined: Thu Mar 12, 2009 11:58 am

Re: changing port to 80 breaks zend backend on mac os x

Post by massimilianoc » Wed Apr 01, 2009 9:47 pm

Yes, I have the latest version.
See what you get running the following command from within Zend Server root:
grep -Ri '1008' *

Any .ini file or .xml that results from the command and carries a directive related to server port is a good candidate for an update (to port 80 of course).

Massi.
Best regards,
Massi.

smithdg
Posts: 41
Joined: Sun Mar 22, 2009 3:32 am

Re: changing port to 80 breaks zend backend on mac os x

Post by smithdg » Thu Apr 02, 2009 5:31 am

That fixed it. The file was zwas.ini.

thanks,
Danny

User avatar
zend_amir
Posts: 64
Joined: Thu Jan 22, 2009 4:27 pm

Re: SOLVED: changing port to 80 breaks zend backend on mac os x

Post by zend_amir » Tue Apr 07, 2009 1:14 pm

In the latest packages zwas.ini no longer exists. Instead we have 2 files in the same location:
zend-server.ini
zend-server-user.ini
This directive appears in zend-server.ini but some updates will override it. If you want the change to be permanent, you should add this directive to zend-server-user.ini and the updates will not override it.

Post Reply