Page 3 of 3

Re: Default username and pass for phpmyadmin

Posted: Sun Jul 17, 2011 8:59 pm
by eraunig
Took some twiddling but here's what you do:

open your config.inc.php file

Change your line that says
$cfg['Servers'][$i]['host'] = 'localhost';
to
$cfg['Servers'][$i]['host'] = '127.0.0.1';

Also change your port to whatever you configured it to ie:

$cfg['Servers'][$i]['port'] = '';
to
$cfg['Servers'][$i]['port'] = '3306';

Change your password to whatever you configured it as
from
$cfg['Servers'][$i]['password'] = '';
to
$cfg['Servers'][$i]['password'] = 'password';

Voila! you are in.

Re: Default username and pass for phpmyadmin

Posted: Tue Sep 06, 2011 1:06 am
by spragty
I also have phpMyAdmin installed and running but when I entered the username "root" and password " "(blank), I can not connect. It shows an error message (# 2002 Mysql server connection not allowed).
please help me to resolve this problem

Re: Default username and pass for phpmyadmin

Posted: Thu Nov 03, 2011 10:15 am
by maitreya_dwaipayan
I guess there might be another instance of MySQL server installed in your system. You might try uninstalling it and reinstalling Zend server again. The MySQL folder should be in the Zend folder. :)

Re: Default username and pass for phpmyadmin

Posted: Mon Jan 23, 2012 10:40 pm
by denbear
I recently reinstalled Zend CE and had this same issue regarding login. I went into my Windows Services control panel [Administration Tools/Services] and found that the service is set to Automatic. Since I had restarted my computer after installation, the installer doesn't prompt you to do so, it wasn't running yet. I right-clicked on the MySQL_ZendServer51 service and selected Start. I was able to login to phpMyAdmin once the service was running using 'root' for user name and no password.

Re: Default username and pass for phpmyadmin

Posted: Thu Feb 02, 2012 4:33 pm
by olemaga
where is the config.inc.php file located? I'm using Mac OS X

Re: Default username and pass for phpmyadmin

Posted: Sun Sep 09, 2012 10:27 pm
by anono123
I was having problems getting into phpmyadmin after installing CE. The login screen would not take user 'root' and nothing for the password. I finally found the problem: mysql was not running. It had been installed as a service on my Win XP machine, and the service hadn't been started. I got into Windows Services, found mysql, started the service up. And then the phpmyadmin screen let me in using user 'root' and nothing for the password.

Re: Default username and pass for phpmyadmin

Posted: Fri Feb 08, 2013 9:51 pm
by x8sws91qwgn-ns7ca-xj
So years later, I also download Community Edition (which promises to let me get a full PHP stack running "in a few minutes").

I am having the same problem, cannot login to MySQL with phpMyAdmin, error #1045 Cannot log in to the MySQL server

I have tried all combinations of admin, root, zend, and null pw or pw = '1234' or pw='zend'

I have tried logging into MySQL from the command line ('mysql -u root ) but same thing.

I have searched forums here and on Stack Overflow.

Lots of people asking the same question. Nobody answering. Actually, the people who are successful are those who have uninstalled Zend and installed WAMP or XAMP.

This is ridiculous.

Re: Default username and pass for phpmyadmin

Posted: Mon Mar 04, 2013 3:44 pm
by zvika
Hi
MySQL default root password is empty/null, so 2 initial modifications to MySQL are:
1. set password for root (from localhost / any host)
2. make sure it listen for connections other than socket (if on Linux / Mac) and if it allows login from your IP.

If you cannot login, check the PHP error log / MySQL log for reason, but it is probably one of the above 2 options for new installation.

Re: Default username and pass for phpmyadmin

Posted: Sat May 18, 2013 3:32 pm
by zein6235
For anyone still struggling with this issue, I fixed it by using a different browser than Chrome.

This is what my config.inc.php file looks like

$i = 0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['ThemeDefault'] = 'metro';

$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['port'] = '3306';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';

And I'm using Firefox now and it's working fine.

Annoying I know. But at least I now know the problem is not the authentication settings of MySQL or phpMyAdmin.

Re: Default username and pass for phpmyadmin

Posted: Mon Jul 01, 2013 6:25 am
by prad2187
Thank you very much :)
it's very useful for me.