Broken dependency on Ubuntu 12.04

General discussion forum for the Zend Server
herophuong
Posts: 1
Joined: Tue Mar 13, 2012 2:41 am

Broken dependency on Ubuntu 12.04

Post by herophuong » Tue Mar 13, 2012 2:48 am

When I marked install "zend-server-ce-php-5.3", the package can not be install becaused of this error

Code: Select all

 "Depends: php-5.3-common-extensions-zend-server but it is not going to be installed". 
Then I tried to install that package, there appeared another error:

Code: Select all

"Depends: php-5.3-imap-zend-server but it is not going to be installed
 Depends: php-5.3-pdo-pgsql-zend-server but it is not going to be installed
Depends: php-5.3-pgsql-zend-server but it is not going to be installed"
Continued to install imap package, the problem has shown itself. The package depends on libkrb53. This package is not going to be installed anymore on 12.04 because it is just a dummy package. I think the right package should be libkrb5-3. Please fix it ASAP.

axhm3a
Posts: 7
Joined: Tue Mar 27, 2012 10:01 am

Re: Broken dependency on Ubuntu 12.04

Post by axhm3a » Tue Mar 27, 2012 10:02 am

yeah, found the same problem last night, screwed my Zend Server installation after upgrading to 12.04

User avatar
mkherlakian_zend
Posts: 88
Joined: Tue Jan 10, 2012 2:41 pm

Re: Broken dependency on Ubuntu 12.04

Post by mkherlakian_zend » Tue Mar 27, 2012 3:10 pm

Have reported the bug to our development team, thank you for reporting.

mikekelly806
Posts: 1
Joined: Sun Apr 08, 2012 12:41 pm

Re: Broken dependency on Ubuntu 12.04

Post by mikekelly806 » Sun Apr 08, 2012 12:47 pm

mkherlakian_zend wrote:Have reported the bug to our development team, thank you for reporting.
This was reported to the development team in January. It is now April and the bug is still there. Is there anywhere that the progress on this issue can be viewed? I am guessing that after all this time it is not worth waiting for a fix and I should look for an alternative solution?

User avatar
kentatzend
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: Broken dependency on Ubuntu 12.04

Post by kentatzend » Mon Apr 09, 2012 4:18 pm

We plan to fix this shortly after the official release ofUbuntu 12.04. We don't generally "chase" pre-releases of OS version.

axhm3a
Posts: 7
Joined: Tue Mar 27, 2012 10:01 am

Re: Broken dependency on Ubuntu 12.04

Post by axhm3a » Thu Apr 12, 2012 10:04 am

I am looking foward to the fix. I hope shortly means same week.
I really dont want to stick around with apache php-5 stack any longer...

igorhaf2008
Posts: 2
Joined: Wed Mar 31, 2010 3:14 pm

Re: Broken dependency on Ubuntu 12.04

Post by igorhaf2008 » Thu Apr 12, 2012 10:14 am

The repository is the problem (http://repos.zend.com/deb/ce/dists/ce/n ... 6/Packages), I have no response with apt-get or when I do it in the browser. ERROR 404

User avatar
ericritchie
Posts: 118
Joined: Tue Feb 10, 2009 10:09 am

Re: Broken dependency on Ubuntu 12.04

Post by ericritchie » Thu Apr 12, 2012 11:23 am

Hi axhm3a,

Let me start by saying that I am not an authority on the repositories, but I have not seen "ce" paths in the repos.zend.com server. What I do know is this: From Zend Server 5.6 onwards there will no longer be a specific CE version available. This means you should install the full version and not license it to have an equivalent CE installation.

So, change your repository to this one:

Code: Select all

deb http://repos.zend.com/zend-server/deb server non-free


and then run the following commands:

Code: Select all

apt-get update
apt-get install zend-server-php-5.3
Lastly, if you don't want to get a trial license (which you probably don't since you want to run CE) then you will need to run

Code: Select all

/usr/local/zend/bin/zs-setup set-password <new password>
/usr/local/zend/bin/zs-setup show-eula
/usr/local/zend/bin/zs-setup accept-eula
This will set your initial GUI password and display the end user license agreement (which I trust you will faithfully read) and then accept it. You can now log into your GUI and use the CE features of Zend Server.

Enjoy (although you will probably have to wait for Ubuntu 12.04 to be fully supported)!

Regards,
Eric Ritchie.

igorhaf2008
Posts: 2
Joined: Wed Mar 31, 2010 3:14 pm

Re: Broken dependency on Ubuntu 12.04

Post by igorhaf2008 » Thu Apr 12, 2012 10:29 pm

the problem persists

axhm3a
Posts: 7
Joined: Tue Mar 27, 2012 10:01 am

Re: Broken dependency on Ubuntu 12.04

Post by axhm3a » Fri Apr 27, 2012 5:23 pm

so...

12.04 has landed. time to keep up for Zend Server.

Post Reply