Mac OS X RewriteRule in .htaccess issue

General discussion forum for the Zend Server
Post Reply
Posts: 11
Joined: Fri Jan 16, 2009 7:21 am
Location: Moscow, Russia

Mac OS X RewriteRule in .htaccess issue

Post by apikulik » Sun Feb 08, 2009 5:53 pm

I've met such a bug while I tried to deploy my 100% working project to my new development platform (ZendServer CE for Mac OS X).
Apache fails to produce rewriting of such directive as:
RewriteRule ^page([0-9]{1,10}).html$ content.php?id=$1
When I open any URL of my project web server displays only blank page.
If I comment that directive in .htaccess file everything works fine.
I tried to catch any data in RewriteLog
To do that I've added to vhost config:
RewriteLog "logs/rewrite.log"
But there's nothing in it. It still stays 0 sized file.

Then, I tried to deploy my project to MAMP server to chec whether it will produce the same error or not.
So, my project works perfect on MAMP in both cases of using of that .htaccess directive (commented and uncommented)

Here is my environment:
Mac OS X 10.5.6 (Leopard)

/Applications/ZendServer/bin/ version
ZendServer version: 4.0.0

/Applications/ZendServer/apache2/bin/httpd -v
Server version: Apache/2.2.10 (Unix)
Server built: Oct 27 2008 12:11:15

User avatar
Posts: 64
Joined: Thu Jan 22, 2009 4:27 pm

Re: Mac OS X RewriteRule in .htaccess issue

Post by zend_amir » Sun Feb 08, 2009 6:39 pm

Thank you for the report.
We reproduced it here and the Apache is crashing on using this rewrite rule. We see in the apache error log "bus error" messages.
We are investigating it and hopefully we will fix it soon.

Post Reply