UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

General discussion forum for the Zend Server
mvysoky
Posts: 13
Joined: Fri May 08, 2009 12:31 am

UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by mvysoky » Fri May 14, 2010 5:08 pm

I am using last Ubuntu server. When install DEB package (all about ZS inst. Guide), all end on broken dependecies. See printscreen. Any other way? Thanks.
Attachments
ubuntu.gif
Printscreen from console
ubuntu.gif (5.97 KiB) Viewed 11454 times

me2resh
Posts: 3
Joined: Wed Jan 14, 2009 5:53 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by me2resh » Mon May 17, 2010 11:11 am

I am encountering the same too, on ubuntu desktop 10.04

below is the full context.

any luck ??

Code: Select all


W: GPG error: http://repos.zend.com server Release: The following signatures were invalid: BADSIG 2EAE1437F7D2C623 Infra team <zp-infra@zend.com>

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
The following packages are BROKEN:
  php-5.2-mysql-zend-server php-5.2-mysqli-zend-server php-5.2-pdo-mysql-zend-server 
The following NEW packages will be installed:
  help-zend-server{a} jobqueue-zend-server{a} jq-daemon-zend-server{a} libaio1{a} libapache2-mod-php-5.2-zend-server{a} libframework1-zend-server{a} libicu36{a} libkrb53{a} libmcrypt4{a} libmhash2{a} liboci-us-locales-zend{a} libpng3{a} libpq4{a} lighttpd-zend-server{a} php-5.2-bcmath-zend-server{a} 
  php-5.2-bz2-zend-server{a} php-5.2-calendar-zend-server{a} php-5.2-code-tracing-zend-server{a} php-5.2-common-extensions-zend-server{a} php-5.2-ctype-zend-server{a} php-5.2-curl-zend-server{a} php-5.2-data-cache-zend-server{a} php-5.2-debugger-zend-server{a} php-5.2-dev-zend-server{a} 
  php-5.2-exif-zend-server{a} php-5.2-fcgi-zend-server{a} php-5.2-ftp-zend-server{a} php-5.2-gd-zend-server{a} php-5.2-gettext-zend-server{a} php-5.2-gui-zend-server{a} php-5.2-imap-zend-server{a} php-5.2-intl-zend-server{a} php-5.2-jq-zend-server{a} php-5.2-json-zend-server{a} php-5.2-ldap-zend-server{a} 
  php-5.2-mbstring-zend-server{a} php-5.2-mcrypt-zend-server{a} php-5.2-mhash-zend-server{a} php-5.2-mime-magic-zend-server{a} php-5.2-monitor-ui-zend-server{a} php-5.2-monitor-zend-server{a} php-5.2-oci8-zend-server{a} php-5.2-optimizer-plus-zend-server{a} php-5.2-page-cache-zend-server{a} 
  php-5.2-pdo-oci-zend-server{a} php-5.2-pdo-pgsql-zend-server{a} php-5.2-pgsql-zend-server{a} php-5.2-posix-zend-server{a} php-5.2-sc-zend-server{a} php-5.2-session-clustering-zend-server{a} php-5.2-soap-zend-server{a} php-5.2-sockets-zend-server{a} php-5.2-sqlite-zend-server{a} php-5.2-tidy-zend-server{a} 
  php-5.2-tokenizer-zend-server{a} php-5.2-xmlreader-zend-server{a} php-5.2-xmlwriter-zend-server{a} php-5.2-xsl-zend-server{a} php-5.2-zds-zend-server{a} php-5.2-zem-zend-server{a} php-5.2-zend-extensions{a} php-5.2-zendutils-zend-server{a} php-5.2-zip-zend-server{a} sc-daemon-zend-server{a} sqlite{a} 
  zend-base{a} zend-server-doc{a} zend-server-framework{a} zend-server-php-5.2 
The following packages will be REMOVED:
  libapache2-mod-php5{a} php5-common{a} php5-mysql{a} 
0 packages upgraded, 72 newly installed, 3 to remove and 0 not upgraded.
Need to get 62.9MB of archives. After unpacking 223MB will be used.
The following packages have unmet dependencies:
  php-5.2-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.
  php-5.2-pdo-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.
  php-5.2-mysqli-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
help-zend-server [Not Installed]
php-5.2-common-extensions-zend-server [Not Installed]
php-5.2-mysql-zend-server [Not Installed]
php-5.2-mysqli-zend-server [Not Installed]
php-5.2-pdo-mysql-zend-server [Not Installed]
zend-server-php-5.2 [Not Installed]

Score is -9836

Accept this solution? [Y/n/q/?] 

marstonstudio
Posts: 20
Joined: Thu Sep 17, 2009 5:21 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by marstonstudio » Mon May 17, 2010 7:11 pm

same here. The problem is that ubuntu 10.04 comes with libmysqlclient16 (5.1.41-3ubuntu12) which is not recognized as a successor to libmysqlclient15off

the deb packages will probably need to rebuilt to fix the broken dependency.

The following packages have unmet dependencies:
php-5.3-pdo-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.
php-5.3-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.
php-5.3-mysqli-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) which is a virtual package.

banzinho
Posts: 2
Joined: Thu May 20, 2010 3:40 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by banzinho » Thu May 20, 2010 3:42 pm

Hi,

Had the same problem, this post helped me to solve the dependencies problem:

http://dereknutile.com/2010/05/02/insta ... ntu-10-04/

Good luck

Banzinho.

stoffel
Posts: 3
Joined: Wed Sep 23, 2009 9:45 am

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by stoffel » Tue Jun 15, 2010 9:02 am

Just install the mysql-common dependency

Code: Select all

apt-get install mysql-common
See:

http://www.god-object.com/2010/06/15/in ... 10-04-lts/

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by jess04 » Tue Jun 22, 2010 3:00 pm

Hello,

Please see here:
viewtopic.php?f=44&t=6641

In addition, this will be resolved once ZendServer 5.0.2 is released which will happen shortly.
Thanks for reporting and let me know if you have further issues.
May the source be with you,

Jess Portnoy

User avatar
kentatzend
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by kentatzend » Wed Jun 23, 2010 5:37 pm

5.0.2 is now released so this should be solved now.

servergirl
Posts: 1
Joined: Tue Mar 15, 2011 9:10 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by servergirl » Wed Mar 16, 2011 1:10 am

kentatzend wrote:5.0.2 is now released so this should be solved now.
Hey, everyone! I've been encountering a lot of the same server installation issues as everyone else. I attempted to check out the link Banzinho posted and that didn't work. I did happen to check out that other thread and I certainly hope to find solution to the issue. Has anyone else resolved the Ubuntu server issue? What did you do? Did ZendServer 5.0.2 just so happen to resolve the issue? Help a girl out! Thanks, guys! :)

One other question, does the ZendServer work at all like business continuity planning software, in which one can do system back ups and so on?
Last edited by servergirl on Thu Mar 17, 2011 4:54 am, edited 1 time in total.

User avatar
kentatzend
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by kentatzend » Wed Mar 16, 2011 4:03 pm

5.0.2 was released long ago and we're up to 5.1 now. Please post more information if you are really still having a problem.

User avatar
liorkaplan
Posts: 108
Joined: Tue Jun 22, 2010 5:59 am

Re: UBUNTU SERVER 10.04 LTS 32 bit instalation - not work

Post by liorkaplan » Sun Apr 03, 2011 12:10 pm

As far as I know there should be no issues installing ZendServer on Ubuntu 10.04 32bit. Let me know if you encounter any problems.

Kaplan

Post Reply