Apache does not process PHP after zend-server fun

General discussion forum for the Zend Server
cc0028
Posts: 14
Joined: Mon Jun 07, 2010 8:53 pm

Apache does not process PHP after zend-server fun

Post by cc0028 » Mon Jun 07, 2010 9:01 pm

Sorry about the title. I ran out of room.

I decided to have another go with ZDE and so thought I'd install Zend Server to get the debugging environment working on my Ubuntu 10.04 32-bit installation. I installed it from the deb package at: http://repos.zend.com/zend-server/deb. However, after installing it I couldn't get it to work and decided to abandon it and uninstall it. I used the Web site instructions (http://files.zend.com/help/Zend-Server- ... lation.htm) to do both the install and the uninstall.

Since doing the uninstall, Apache no longer parses PHP files. I checked /var/messages and the apache error log, but couldn't find anything.

Clearly I've done something stupid, but if somebody could tell me what it is, I'd be very grateful.

Cheers


Peter
http://www.peredur.net

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Apache does not process PHP after zend-server fun

Post by zvika » Tue Jun 08, 2010 6:50 am

Hi

You can perform the following it might resolve the problem right away.
Apache restart should be done by package post installation, or you can restart Apache yourself.
# aptitude update
# aptitude install libapache2-mod-php5
# /etc/init.d/apache2 restart

I would invite you to share your bad experience and post a new topic if you want to re-check our software,
we have numerous users developing on Ubuntu and other Debian based systems and are very happy with the combination of Zend Studio-Server-Framework for all their PHP needs. You can take another look at the product pages to learn about the features and benefits that these products offer, even in the community (free) editions.

Good Luck!
Zvika Dror
Zend Support Team

cc0028
Posts: 14
Joined: Mon Jun 07, 2010 8:53 pm

Re: Apache does not process PHP after zend-server fun

Post by cc0028 » Tue Jun 08, 2010 7:41 am

Thanks for your answer, but I already restarted Apache - not least because the machine has restarted a number of times since the installation/uninstallation.

I'd love to get it all working and I did try to contact Zend with some questions, but never got a reply. That's one of the reasons why I did the uninstall: which I now rather regret, as you can imagine.

:(

Cheers


Peter
http://www.peredur.net

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Apache does not process PHP after zend-server fun

Post by jess04 » Tue Jun 08, 2010 10:09 am

Hello Peter,

The restart is the less important part :)
Do you currently have the Apache PHP module installed from the distro's repository? You can verify with:

Code: Select all

# dpkg -l libapache2-mod-php5
If it returns something like:
ii libapache2-mod-php 5.2.6.dfsg.1-1+len server-side, HTML-embedded scripting language

Then its installed. If not, please install it. Also, if it still doesn't work, I'd check: /var/log/apache2/error.log.

About ZendServer, if you'd like, feel free to describe your issue[s] here and we'll do our best to assist you.

Thanks in advance,
May the source be with you,

Jess Portnoy

cc0028
Posts: 14
Joined: Mon Jun 07, 2010 8:53 pm

Re: Apache does not process PHP after zend-server fun

Post by cc0028 » Tue Jun 08, 2010 11:20 am

Thanks, Jess. I won't be able to get near my development box until this evening, but I'll check that as soon as I get back and then reply.

Many thanks for your time on this.

Cheers


Peter
http://www.peredur.net

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Apache does not process PHP after zend-server fun

Post by jess04 » Tue Jun 08, 2010 11:33 am

Hi Peter,

Of course, you're quite welcome.
Let me know how it went.
May the source be with you,

Jess Portnoy

cc0028
Posts: 14
Joined: Mon Jun 07, 2010 8:53 pm

Re: Apache does not process PHP after zend-server fun

Post by cc0028 » Tue Jun 08, 2010 6:25 pm

I ran dpkg as suggested. It returned this:

peter@peter-linux:~$ sudo dpkg -l libapache2-mod-php5
[sudo] password for peter:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii libapache2-mod 5.3.2-1ubuntu4 server-side, HTML-embedded scripting languag
peter@peter-linux:~$

Not being entirely sure what that meant, I did an uninstall of the library and then reinstalled it and now all is well.

I'll start a new topic for my inability to get Zend Server to work.

Thanks for your help.

Cheers


Peter

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Apache does not process PHP after zend-server fun

Post by jess04 » Tue Jun 08, 2010 6:31 pm

Hi Peter,

Glad to hear all is well.
And, yes, you're quite welcome to open a thread with the issue you had, I'm sure we can work on a solution :)
May the source be with you,

Jess Portnoy

cc0028
Posts: 14
Joined: Mon Jun 07, 2010 8:53 pm

Re: Apache does not process PHP ... [SOLVED]

Post by cc0028 » Tue Jun 08, 2010 6:32 pm

Sorry to reply to myself, but I wanted to mark the thread solved. Also I think it's the Zend Platform I want rather than the Zend Server. So I'm going to give that a go before bothering the forum again.

Cheers


Peter
http://www.peredur.net

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Apache does not process PHP after zend-server fun

Post by jess04 » Wed Jun 09, 2010 6:48 am

Hi Peter,

May I ask why you think Zend Platform is better suitable for your needs? In principle, Zend Server is Zend Platform's successor and so, I would strongly recommend you use that.
If there's anything I can do to help, do let me know.
May the source be with you,

Jess Portnoy

Post Reply