Broken dependency on Ubuntu 12.04

General discussion forum for the Zend Server

Re: Broken dependency on Ubuntu 12.04

Postby farstar78 on Sat Apr 28, 2012 10:39 am

I'm also waiting for 12.04 fix
farstar78
 
Posts: 1
Joined: Sat Apr 28, 2012 10:38 am

Re: Broken dependency on Ubuntu 12.04

Postby alxshr on Sun Apr 29, 2012 2:17 pm

Help!!! Same issue afetr upgrade to 12.04!
alxshr
 
Posts: 2
Joined: Wed Nov 16, 2011 10:43 am

Re: Broken dependency on Ubuntu 12.04

Postby brinleyang on Sun Apr 29, 2012 3:14 pm

Hi,

I'm in the same situation after upgrading to Ubuntu 12.04.

To work around this, I had make a quick hack and remove the dependency on libkrb in libpq and php-5.3-imap-zend-server deb packages and manually installing the packages after which installing zend server ce should work.
However, this will most likely break postgres and imap zend modules so it may not be the solution for people who require those modules.

I have attached the deb packages to this post, note that these are 64 bit packages

Regards,
Brinley
Attachments
fixed_deb.zip
libpq and php-5.3-imap-zend-server deb packages without conflicting depencency
(804.13 KiB) Downloaded 148 times
brinleyang
 
Posts: 1
Joined: Sun Apr 29, 2012 3:05 pm
Location: Australia

Re: Broken dependency on Ubuntu 12.04

Postby axhm3a on Mon Apr 30, 2012 6:43 am

thank you, i will give it a try.
axhm3a
 
Posts: 7
Joined: Tue Mar 27, 2012 10:01 am

Re: Broken dependency on Ubuntu 12.04

Postby john_doe_zend on Tue May 01, 2012 7:06 am

Thnank you, brinleyang, for posting the solution!

Thought I'll share details about how I managed to create 32-bit version:

* I've downloaded libpq4_8.1.17-1_i386.deb and php-5.3-imap-zend-server_5.3.9+b261_i386.deb to my local workstation (they were located at /var/cache/apt/archives/ on server)

* Extracted the contents

cd /tmp/folder_where_contents_will_be_extracted/
dpkg-deb -x /path/to/php-5.3-imap-zend-server_5.3.9+b261_i386.deb .
dpkg-deb -e /path/to/php-5.3-imap-zend-server_5.3.9+b261_i386.deb

* Removed the dependency on libkrb53 and php-5.3-zend-server

Look for "DEBIAN/control" file in extracted content. It contains a line like this:

Depends: libc6 (>= 2.3.6-6), libcomerr2 (>= 1.33-3), libkrb53 (>= 1.4.2), libssl0.9.8 (>= 0.9.8c-1), php-5.3-zend-server

The result after modification would look like this:

Depends: libc6 (>= 2.3.6-6), libcomerr2 (>= 1.33-3), libssl0.9.8 (>= 0.9.8c-1)

* Rebuilt DEB package

dpkg-deb -b . ../php-5.3-imap-zend-server_5.3.9+b261_i386.deb

* Uploaded packages back to server and installed them manually

dpkg -i libpq4_8.1.17-1_i386.deb
dpkg -i php-5.3-imap-zend-server_5.3.9+b261_i386.deb

* Successfully installed Zend Server

apt-get install zend-server-php-5.3
john_doe_zend
 
Posts: 1
Joined: Tue May 01, 2012 6:57 am

Re: Broken dependency on Ubuntu 12.04

Postby dirkdorony on Wed May 02, 2012 4:14 pm

ETA on the repo fix? I'm still seeing the problem as well.
dirkdorony
 
Posts: 1
Joined: Wed May 02, 2012 4:13 pm

Re: Broken dependency on Ubuntu 12.04

Postby sirshurf on Wed May 02, 2012 4:53 pm

sirshurf
 
Posts: 14
Joined: Thu Feb 26, 2009 11:25 am

Re: Broken dependency on Ubuntu 12.04

Postby bobonov on Thu May 03, 2012 7:26 am

"We don't generally "chase" pre-releases of OS version."
Sorry but I have to say that this is a nonsense answer.
pre-release of os are there just to test that everything work before the os is released and fix problem BEFORE people upgrade the os.
Once the os is released people upgrade and they obtain a non working zend server installation.
If you decide to not work in order to prevent problems at least ADVICE people to not upgrade to 12.04 until a fix is released with an announce on the website.
bobonov
 
Posts: 8
Joined: Wed Apr 15, 2009 3:40 pm

Re: Broken dependency on Ubuntu 12.04

Postby kentatzend on Thu May 03, 2012 6:47 pm

Bobonov,

I'm sorry you think my response is "nonsense" but frankly I would have to say your overall expectations are a bit unrealistic.

First, I'm not sure I agree the reason that "pre-releases" of new OS version are made available is totally correct (I actually this it's more to get people to test the OS itself) but it certainly would be possible for ISV to use these to test OS versions in advance of the new release. But people probably realize that this kind of testing is not "free" for an ISV. It involves adding one more combination to an already pretty deep testing matrix (I think at last count we had something like 120 variation we test on). So we choose to wait for testing a new OS version until the official release is made. Why? Because we have been burned in the past by "late breaking changes" even between RCs and final releases. So we will probably never release on the same day as a new OS version.

Second, as a reasonable human being I know that OS upgrades can (and often do) break things. As such I would first confirm that any software I wanted to use on that OS actually worked on a test machine. If it did not then I might delay my decision to update other machines (or I might decide I don't need that software or ...). If I didn't do this I'd certainly hope I was smart enough to make a backup or snapshot before I upgraded so I could always revert in case of some problem. If I didn't take these reasonable actions I'm not sure I'd complain to the ISV ... I'd probably kick myself for "being stupid".

Lastly, I'm always amazed at the resourcefulness of people and how they can come up with workarounds to stuff. But I do want to warn people that officially we have not done a QA sweep for this release. Fixing the dependency issue to let it install does not necessarily mean that he product actually will work correctly after it is installed. It might but it also might not. We simply have not run a full QA sweep on this version. Until we do we will not officially be supporting this release. Best case scenarios is that it could take 2-3 weeks (or longer) for us to run a full QA sweep and to publish a new release. Also as some below pointed out this hack of the dependencies might break future updates from Zend when we do make an official release.

So if you really don't have to update to 12.04 immediately it might be better to wait for an update from Zend. If you have a compelling need to update feel free, just be aware Zend's standard install won't work and you're ending up in an unsupported configuration.

Kent Mitchell
DIrector, Product Mgmt
Zend

Kent
User avatar
kentatzend
 
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: Broken dependency on Ubuntu 12.04

Postby axhm3a on Fri May 04, 2012 10:28 am

Dear Kent,

thank you for explaining to us the reasons for the delay.
i just hope that your QA guys dont mind to take 1 or 2 extra shifts.
while i am sticking to the standart php stack,
i am looking forward to a new release of zend server.

kind regards,

daniel
axhm3a
 
Posts: 7
Joined: Tue Mar 27, 2012 10:01 am

PreviousNext

Return to Zend Server

Who is online

Users browsing this forum: No registered users and 10 guests