i5_connect failing

General discussion on Zend Server for IBM System i
Post Reply
kris6674
Posts: 1
Joined: Mon Dec 18, 2017 8:23 pm

i5_connect failing

Post by kris6674 » Mon Dec 18, 2017 8:31 pm

Hi,

Can somebody help me on the below issue.

Our PHP code is using i5_connect to connect to Iseries server to run certain command and its failing.

We are still on Zendserver 5 using community version. recently upgraded our Iseries version to V7R2.

That was working fine before the OS upgrade but failing after OS upgrade.

I tried the following things:
1. go zendsvr/zstmenu

2. Then selected option 1. Start PHP Toolkit service
Library . . . . . . . . . . . . > ZENDSVR
i5_COMD Service Port number . . 6079
Enable Prestart Jobs . . . . . . *OFF
Restart i5_COMD if running . . . *NO

3. when i check the joblog , it gives an error
EASYCOMD not running, port=6079: A remote host refused an attempted
connect operation.

we are going to upgrade the zend to latest licensed version in 2018 first quarter.
So we need some temporary fix for this till then.
Any help to resolve this is highly appreciated.

Thanks
Krishna

dura8336
Posts: 1
Joined: Thu Jan 11, 2018 6:05 pm
Contact:

Re: i5_connect failing

Post by dura8336 » Thu Jan 11, 2018 6:07 pm

I have the same problem!

alan8630
Posts: 1
Joined: Thu Feb 15, 2018 5:50 pm
Contact:

Re: i5_connect failing

Post by alan8630 » Thu Feb 15, 2018 5:52 pm

This is the problem to same peoples.

sam3047
Posts: 12
Joined: Wed Nov 02, 2016 9:27 am

Re: i5_connect failing

Post by sam3047 » Sun Feb 18, 2018 7:46 am

It looks like Easycom requires license after OS upgrade. Check QSYSOPER message queue

marc5457
Posts: 1
Joined: Sat Mar 03, 2018 1:00 pm
Contact:

Re: i5_connect failing

Post by marc5457 » Sat Mar 03, 2018 1:05 pm

I have the same problem!

sidn7670
Posts: 1
Joined: Tue Mar 06, 2018 8:39 pm
Contact:

Re: i5_connect failing

Post by sidn7670 » Tue Mar 06, 2018 8:42 pm

I have the same problem!

manu2132
Posts: 1
Joined: Wed Mar 14, 2018 4:13 pm
Contact:

Re: i5_connect failing

Post by manu2132 » Wed Mar 14, 2018 4:15 pm

It looks like Easycom requires license after OS upgrade. Check QSYSOPER message queue

cris3641
Posts: 1
Joined: Wed Apr 18, 2018 8:45 pm
Contact:

Re: i5_connect failing

Post by cris3641 » Wed Apr 18, 2018 8:51 pm

It does not seem like a very difficult problem to solve.

Post Reply