ZendDBi (Maria 10.1) on IBMi crashes when creating tables

General discussion on Zend Server for IBM System i
Post Reply
wesl67
Posts: 13
Joined: Fri Feb 14, 2014 9:13 pm

ZendDBi (Maria 10.1) on IBMi crashes when creating tables

Post by wesl67 » Thu Dec 20, 2018 8:34 pm

We have installed the ZendDBi 10.1 on our iSeries. I'm able to login to the server from mysql workbench and I can create a table using the innodb driver.
However when I attempt to create a table using the IBMDB2I driver I get the error:
ERROR 2013: Lost connection to MySQL server during query

Sure enough the ZendDBi service has stopped. Normally I would attempt to get information via the job log but I can't because the job is no longer running.

I'm using this as the create table statement
CREATE TABLE `DUMMY`.`new_table123` (
`idnew_table123` VARCHAR(45) NOT NULL,
PRIMARY KEY (`idnew_table123`))
ENGINE = IBMDB2I;

I can see the IBMDB2I plugin listed under 'show engines'. I installed the IBMDB2I plugin with:
install plugin ibmdb2i soname 'ha_ibmdb2i.so';

Does anyone know how to get more information here?

timclark2000
Posts: 70
Joined: Fri May 01, 2009 8:19 pm

Re: ZendDBi (Maria 10.1) on IBMi crashes when creating tables

Post by timclark2000 » Wed Jan 02, 2019 4:41 pm

The mariadb error log should give you some additional clues. It is located in the mariadb data directory. By default this would be a file named /usr/local/mariadbdata/[your system name].err

Look at the end of that file after the crash occurs.

wesl67
Posts: 13
Joined: Fri Feb 14, 2014 9:13 pm

Re: ZendDBi (Maria 10.1) on IBMi crashes when creating tables

Post by wesl67 » Wed Jan 02, 2019 11:09 pm

That was a good thought but sadly all it says is 'ibmdb2i error 2021: See message in joblog for job //.'

timclark2000
Posts: 70
Joined: Fri May 01, 2009 8:19 pm

Re: ZendDBi (Maria 10.1) on IBMi crashes when creating tables

Post by timclark2000 » Thu Jan 03, 2019 4:34 pm

Does the system already have a user profile named DUMMY by any chance? Or, alternately, does this fail if you use a schema name that doens't correspond to a user profile (maybe DUMMY2)?

I'm seeing behavior similar to yours on my system when the MySQL schema has the same name as an existing user profile. It doesn't seem right to me, so I'm going to do some further research.

wesl67
Posts: 13
Joined: Fri Feb 14, 2014 9:13 pm

Re: ZendDBi (Maria 10.1) on IBMi crashes when creating tables

Post by wesl67 » Thu Jan 03, 2019 11:03 pm

Interesting I do have a user named 'DUMMY' on the system. I will have to try creating a new schema later.

Post Reply