failed retrieving "downloadService" ... class does not exist

General discussion on Zend Studio

Moderator: natalia_b_zend

failed retrieving "downloadService" ... class does not exist

Postby rich1105 on Tue Sep 17, 2013 12:43 am

I sent email to Zend ... got back reply to post to this Forum.
I am copy-n-pasting that email.

But things ain't going so well :-(
Every time I try to Preview/Submit ... I get error msg ...
You are not authorized to post url links, please remove or rename:

I have tried umpteen ways to spoof the system to allow my URLs as text, etc.
Not work.
So am editing this ... will save as HTML file ... and try to UPLOAD it as attachment.

NOPE ... that FAILED also.
"The extension html is not allowed"

Will Try Again ... but as RTF file.





I had to REMOVE URLs from text below ... to POST to Forum.

But "hopefully" ... if you upload the attached file ... those URLs will re-appear.



MY QUESTION

I have been "trying" to follow one of the tutorials for Zend Studio ... but nothing I try seems to work.
*********************************** URL Removed **********************************

I registered for PHPCloud ... and was deploying to it ... and all worked OK.
Problem came at STEP #2 where I was trying to CREATE and REGISTER a New Service.
I am getting following error msg.

ERROR MSG ...
Zend\ServiceManager\ServiceManager::createFromInvokable: failed retrieving "downloadservice(alias: downloadService)" via invokable class "Downloads\src\Downloads\DownloadsService"; class does not exist

I have posted my question and screenshots to this link ...
*********************************** URL Removed **********************************


I zipped up the Zend project code here ...
*********************************** URL Removed **********************************



Any ideas/suggestions on what I am doing wrong.
Please see screenshots in link above.

Thank you.
Attachments
ZendForumPost.rtf
(7.56 KiB) Downloaded 94 times
rich1105
 
Posts: 4
Joined: Mon Sep 16, 2013 11:13 pm

Re: failed retrieving "downloadService" ... class does not e

Postby rich1105 on Tue Sep 17, 2013 5:42 am

"Finally" got it to work (naturally, after posting my question :-) )

Problem was singular vs plural
Download
vs
Downloads

And PATH in Properties > Zend Framework > Service Locator > NAME (singular vs plural) ... TYPE (path)

I will "diff" the 2 projects tomorrow to find the exact differences.

Thanx.
rich1105
 
Posts: 4
Joined: Mon Sep 16, 2013 11:13 pm


Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 6 guests