Connection refused.

General discussion forum for the Zend Server

Connection refused.

Postby yuvilio on Wed Aug 18, 2010 9:30 pm

Hey all,

Pardon the noob question that's probably been answered a lot.

I installed zend on my debian box. It gave me the usual INSTALLATION SUMMARY message afterwards which included "Web interface is accessible from https://localhost:10082/ZendServer"

So after installing it. I tried testing it with a wget command on that box but got a "Connection refused" error:

Code: Select all
yuval@php-website:/etc/apache2$ wget --no-check-certificate https://localhost:10082/ZendServer
--2010-08-18 20:40:12--  https://localhost:10082/ZendServer
Resolving localhost... 127.0.0.1
Connecting to localhost|127.0.0.1|:10082... failed: Connection refused.
yuval@php-website:/etc/apache2$


the processes seem up. Here's a snippet from a ps command:
Code: Select all
yuval@php-website:/etc/apache2$ ps aux | grep -i zend
yuval    17326  0.0  0.0   3256   532 pts/31   S+   20:35   0:00 tail -f /usr/local/zendphp52/zend/var/log/error.log
root     17533  0.0  1.1 151460 23020 ?        Ss   20:36   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon   17563  0.0  0.9 151364 18624 ?        S    20:36   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start

.....


it DOES seem to be listening in the 10088 port (per it's message "Apache is up and running on port 10088!" in the INSTALLATION SUMMARY)
Code: Select all
yuval@php-website:~$ wget http://localhost:10088           
--2010-08-18 20:43:12--  http://localhost:10088/
Resolving localhost... 127.0.0.1
Connecting to localhost|127.0.0.1|:10088... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2261 (2.2K) [text/html]
Saving to: "index.html"

100%[===================================================================================================================================================================================================>] 2,261       --.-K/s   in 0s     

2010-08-18 20:43:12 (134 MB/s) - "index.html" saved [2261/2261]

yuval@php-website:~$



here's a netstat if that helps:
Code: Select all
yuval@php-website:/etc/apache2$ sudo netstat -nlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 192.168.20.100:80       0.0.0.0:*               LISTEN      16992/apache2   
tcp        0      0 192.168.20.100:22       0.0.0.0:*               LISTEN      7145/sshd       
tcp        0      0 0.0.0.0:90              0.0.0.0:*               LISTEN      16992/apache2   
tcp        0      0 127.0.0.1:10083         0.0.0.0:*               LISTEN      17533/httpd     
tcp        0      0 0.0.0.0:10088           0.0.0.0:*               LISTEN      17533/httpd     
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node   PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     102433968 17574/php           /usr/local/zendphp52/zend/gui/lighttpd/tmp/php-fastcgi.socket
unix  2      [ ACC ]     STREAM     LISTENING     96835631 7585/dtach          /tmp/root-emacs
unix  2      [ ACC ]     STREAM     LISTENING     96834138 7127/dbus-daemon    /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     100560600 5798/dtach          /tmp/zope-emacs
yuval@php-website:/etc/apache2$


Does anyone have any idea what I'm missing?

Thanks!

Yuval
yuvilio
 
Posts: 6
Joined: Tue Aug 18, 2009 11:11 pm

Re: Connection refused.

Postby liorkaplan on Thu Aug 19, 2010 11:33 am

Hi Yuval,

From your netstat output it seems that no process is listening to ports 10081 and 10082.
Please try to restart lighttpd with the command:
Code: Select all
/usr/local/zend/bin/zendctl.sh restart-lighttpd

then check again about the port in use.

Kaplan
User avatar
liorkaplan
 
Posts: 93
Joined: Tue Jun 22, 2010 5:59 am

Re: Connection refused.

Postby yuvilio on Thu Aug 19, 2010 1:44 pm

Hey Kaplan,

Thanks for the quick reply. I tried that command which suggests it is bringing up lighttpd for the zend management app, but to no avail (see wget and netstat after):

Code: Select all
yuval@php-website:~$ sudo /usr/local/zendphp52/zend/bin/zendctl.sh restart-lighttpd
lighttpd is not running
spawn-fcgi: child spawned successfully: PID: 8269
Starting Zend Server GUI [Lighttpd] [OK]
yuval@php-website:~$ wget --no-check-certificate https://localhost:10082/ZendServer
--2010-08-19 12:52:18--  https://localhost:10082/ZendServer
Resolving localhost... 127.0.0.1
Connecting to localhost|127.0.0.1|:10082... failed: Connection refused.
yuval@php-website:~$ sudo netstat -nlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 192.168.20.100:80       0.0.0.0:*               LISTEN      16992/apache2   
tcp        0      0 192.168.20.100:22       0.0.0.0:*               LISTEN      7145/sshd       
tcp        0      0 0.0.0.0:90              0.0.0.0:*               LISTEN      16992/apache2   
tcp        0      0 127.0.0.1:10083         0.0.0.0:*               LISTEN      17533/httpd     
tcp        0      0 0.0.0.0:10088           0.0.0.0:*               LISTEN      17533/httpd     
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node   PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     102526093 8269/php            /usr/local/zendphp52/zend/gui/lighttpd/tmp/php-fastcgi.socket
unix  2      [ ACC ]     STREAM     LISTENING     96835631 7585/dtach          /tmp/root-emacs
unix  2      [ ACC ]     STREAM     LISTENING     96834138 7127/dbus-daemon    /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     100560600 5798/dtach          /tmp/zope-emacs
yuval@php-website:~$



tailing my zend/var/log/zem.log file I saw this upon restart:

Code: Select all
[:: Zend Extension Manager :: 19.08.2010 12:52:11 WARNING] [ ZendExtensionManager.cpp : 1182 ( zend_extension_manager_startup ) ] Will not load extension 'datacache': can not find none of keys: ('zend_extension_manager.dir.datacache', 'zend_extension_manager.datacache')



I didn't see anything in the zend/var/log/gui_vhost_eror.log or the zend/var/log/error.log for the lightthpd restart.

Did I not configure something or install some prerequisite?

Yuval
yuvilio
 
Posts: 6
Joined: Tue Aug 18, 2009 11:11 pm

Re: Connection refused.

Postby yuvilio on Thu Aug 19, 2010 2:13 pm

To add more confirmation, both the apache and lighttpd processes seem up even though the connection is refused for lighty

Code: Select all
yuval@php-website:~$ ps aux | grep -i zend
root      9467  6.0  1.1 151460 23020 ?        Ss   13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9497  0.0  0.9 151364 18624 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9498  0.0  0.9 151460 19044 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9499  0.0  0.9 151460 19032 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9500  0.0  0.9 151460 19032 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9501  0.0  0.9 151460 19032 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
daemon    9502  0.0  0.9 151460 19032 ?        S    13:28   0:00 /usr/local/zendphp52/zend/apache2/bin/httpd -f /usr/local/zendphp52/zend/apache2/conf/httpd.conf -k start
zend      9508  0.3  0.2  80520  5780 ?        Ss   13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
zend      9509  0.0  0.1  80520  3260 ?        S    13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
zend      9510  0.0  0.1  80520  3260 ?        S    13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
zend      9511  0.0  0.1  80520  3260 ?        S    13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
zend      9512  0.0  0.1  80520  3260 ?        S    13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
zend      9513  0.0  0.1  80520  3260 ?        S    13:28   0:00 /usr/local/zendphp52/zend/gui/lighttpd/sbin/php -c /usr/local/zendphp52/zend/gui/lighttpd/etc/php-fcgi.ini
yuval     9532  0.0  0.0   3368   768 pts/0    S+   13:28   0:00 grep -i zend
yuval@php-website:~$


yuvilio
 
Posts: 6
Joined: Tue Aug 18, 2009 11:11 pm

Re: Connection refused.

Postby yuvilio on Thu Aug 19, 2010 9:56 pm

Think I'm getting warmer. Tried running the lighttpdctl.sh process directly and got this error:

Code: Select all
yuval@php-website:/etc/apache2/sites-enabled$ sudo /usr/local/zendphp52/zend/bin/lighttpdctl.sh --debug restart
lighttpd is not running
spawn-fcgi: child spawned successfully: PID: 14384
[ 19.08.2010 21:11:14 SYSTEM] watchdog for lighttpd is not running.
[ 19.08.2010 21:11:14 SYSTEM] lighttpd is not running.
Starting Zend Server GUI [Lighttpd] [OK]
yuval@php-website:/etc/apache2/sites-enabled$ [ 19.08.2010 21:11:14 SYSTEM] waiting for process 14395
[ 19.08.2010 21:11:14 SYSTEM] Executing: /usr/local/zendphp52/zend/gui/lighttpd/sbin/lighttpd -m /usr/local/zendphp52/zend/gui/lighttpd/lib -f /usr/local/zendphp52/zend/gui/lighttpd/etc/lighttpd.conf -D
2010-08-19 21:11:14: (network.c.201) socket failed: Address family not supported by protocol
yuvilio
 
Posts: 6
Joined: Tue Aug 18, 2009 11:11 pm

Re: Connection refused.

Postby yuvilio on Fri Aug 20, 2010 3:20 pm

i saw somewhere that this change might fix it so I edited the zend/gui/lighttpd/etc/lighttpd.conf file

Code: Select all
server.use-ipv6 = "disable"


But got the same error:
Code: Select all
yuval@php-website:~$ [ 20.08.2010 14:34:38 SYSTEM] waiting for process 24740
[ 20.08.2010 14:34:38 SYSTEM] Executing: /usr/local/zendphp52/zend/gui/lighttpd/sbin/lighttpd -m /usr/local/zendphp52/zend/gui/lighttpd/lib -f /usr/local/zendphp52/zend/gui/lighttpd/etc/lighttpd.conf -D
2010-08-20 14:34:38: (network.c.201) socket failed: Address family not supported by protocol


still stuck
yuvilio
 
Posts: 6
Joined: Tue Aug 18, 2009 11:11 pm

Re: Connection refused.

Postby liorkaplan on Thu Sep 02, 2010 12:40 pm

Hi Yuval,

Does your machine support IPv6 ? I found a similar case which this was the problem.

Kaplan
User avatar
liorkaplan
 
Posts: 93
Joined: Tue Jun 22, 2010 5:59 am

Re: Connection refused.

Postby seanman05 on Sat Sep 04, 2010 6:08 pm

I have a similar problem, thanks for the info.
seanman05
 
Posts: 1
Joined: Sat Sep 04, 2010 6:08 pm

Re: Connection refused.

Postby edac on Sun Sep 05, 2010 9:09 am

Solved:
replace "/usr/local" by your installation path
open /usr/local/zend/gui/lighttpd/etc/lighttpd.conf
replace line
Code: Select all
$SERVER["socket"] == "[::]:10082"  {

with
Code: Select all
$SERVER["socket"] == ":10082"  {

and line
Code: Select all
server.use-ipv6 = "enable"

with
Code: Select all
server.use-ipv6 = "disable"

Then run:
Code: Select all
/usr/local/zend/bin/zendctl.sh setup-jb
/usr/local/zend/bin/zendctl.sh restart
edac
 
Posts: 1
Joined: Sun Sep 05, 2010 9:04 am

Re: Connection refused.

Postby vuolot on Fri Sep 17, 2010 5:20 pm

Thanks edac! I figured out the disable ipv6 part, but not the socket line. Then I found your post and it probably saved me HOURS.
vuolot
 
Posts: 13
Joined: Wed Jul 22, 2009 6:09 pm
Location: Denver, CO


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 8 guests