Page 1 of 1

PgmCall question

Posted: Wed May 27, 2015 10:08 pm
by mike8929
I create the connection for some SQL queries:
$conn = db2_pconnect($DataBase, $User, $PassWord);
My SQL stuff works fine with this connection, however when I try to call a program:
$ToolkitServiceObj = ToolkitService::getInstance($conn);

$ToolkitServiceObj->setToolkitServiceParams(array('stateless'=>true));
$params[] = $ToolkitServiceObj->AddParameterZoned('both',8,0,'Date','TESTDATE','0');

$result = $ToolkitServiceObj->PgmCall('GET3DAYS3','SWAAPP',$params,null,null);

I get "XML run loop failed (p(54)"

I admit I'm new to Zend but I'm not seeing my problem. Any help would be tremendously appreciated.

Re: PgmCall question

Posted: Fri May 29, 2015 3:48 am
by aseiden
Hi, Mike,

Your PHP code looks good. If you'll create a debug log then we can see what's wrong.

Turn on the debug log at any point before the program call:

Code: Select all

$ToolkitServiceObj->setOptions(array('debug'=>true)); // setOptions is an alias for setToolkitServiceParams
Run your script, then look for the debug.log file in /usr/local/zendsvr6/var/log/debug.log. Post the log here on the forum and we'll help figure out what's wrong.

-- Alan Seiden

Re: PgmCall question

Posted: Mon Jan 29, 2018 8:06 pm
by beat1108
I have this problem too....

Re: PgmCall question

Posted: Mon Mar 26, 2018 1:50 am
by zepe6667
I have this problem too.

Re: PgmCall question

Posted: Wed Apr 18, 2018 3:42 pm
by kaio2653
This "XML run loop failed (p(54)" is a truly pain.
I used to get it all the time.

Try the procedure aseiden recomended (it wordked or me).