Page 1 of 1

Debugging issue with Studio 11.0

Posted: Fri Aug 22, 2014 2:32 pm
by d_11_27
We've upgraded to Zend Studio 11.0 and Zend Server 7.0 on IBM i. Z-Ray looks great, but apparently does not work over https, so I am attempting to debug. Z-Ray's toolbar debug worked great (from browser to studio and broke on 1st line). However, I cannot get my browser's Zend toolbar (2.7 version) to break. It keeps stating: Failed to connect to host '127.0.0.1'. Failed to connect to host 'xxx.xxx.xxx.xxx'. In the toolbar settings, I can click on test the connection and it tests just fine. I have turned off Z-Ray, but it still does not work. Is there a setting someplace I am missing?

Re: Debugging issue with Studio 11.0

Posted: Mon Sep 08, 2014 3:32 pm
by d_11_27
Got a response from Zend, it was a simply fix:

From the Zend Studio tool bar -> Windows -> Preferences -> PHP ->
Debug -> Installed Debuggers

Select the "Zend Debugger" and click the "configure" button.

Change the value in the "Client host IP to Include your Studio IP Address and remove the 127.0.0.1 entry or make it the second entry. (example: 10.2.1.1, 127.0.0.1)

My IP address was listed as the 2nd one, I changed it the first and it worked.