Zend Server for IBMi Installation issues

General discussion on Zend Server for IBM System i
Post Reply
grah7845
Posts: 2
Joined: Fri Mar 11, 2016 11:11 am

Zend Server for IBMi Installation issues

Post by grah7845 » Tue Mar 15, 2016 1:32 pm

After zero response I thought I would just go ahead and try and install the damn thing.

We running a Power7 processor feature p05 we have one iOS partition, one Linux partition and one viOS partion. OS400 version 7.1 and Red Hat Enterprise Linux Server release 7.2 (Maipo).

I tried both ZendServer-8.5.3-RepositoryInstaller-linux-power8.tar.gz and ZendServer-8.5.3-RepositoryInstaller-linux.tar.gz. Both have the same error.

There does not appear to be a Power7 specific version (I have downloaded, but not tried installing ZendServer-7.0.0-RepositoryInstaller-linux.tar.gz).

I am having to break up the urls as
You are not authorized to post url links, please remove or rename:
install_zs. sh
If you visit the following url:
http://repos.zend. com/zend-server/8.5/rpm_apache2.4/
You will see that the actual folder is called ppc64le and not ppc64 as expected by the install script.
root@LX400:~/ZendServer-RepositoryInstaller-linux# ./install_zs. sh 5.6

Running this script will perform the following:
* Configure your package manager to use Zend Server repository
* Install Zend Server (PHP 5.6) on your system using your package manager

Hit ENTER to install Zend Server (PHP 5.6), or Ctrl+C to abort now.

Tool for checking existing installation: /usr/bin/rpm
Doing repository configuration for: /usr/bin/yum
Package manager for installation: /usr/bin/yum
Loaded plugins: product-id, search-disabled-repos, subscription-manager
http://repos.zend. com/zend-server/8.5/rpm_apache2.4/ppc64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat. com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.



One of the configured repositories failed (Zend Server),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Disable the repository, so yum won't use it by default. Yum will then
just ignore the repository until you permanently enable it again or use
--enablerepo for temporary usage:

yum-config-manager --disable Zend

4. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=Zend.skip_if_unavailable=true

failure: repodata/repomd.xml from Zend: [Errno 256] No more mirrors to try.
http://repos.zend. com/zend-server/8.5/rpm_apache2.4/ppc64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
package zend-server-php-5.6 is not installed
package zend-server-php-5.6-common is not installed

************************************************************************************************
* Zend Server Installation was not completed. See output above for detailed error information. *
************************************************************************************************

Log file is kept at /tmp/install_zs.log.2971

And the log has this to say:
Supported OS regex: CentOS|Red Hat Enterprise Linux Server|SUSE|Debian GNU/Linux|Ubuntu|Oracle Linux Server
Current OS detected as: Red Hat Enterprise Linux Server release 7.2 (Maipo)
Support for the following OS has been stopped: CentOS release 5|Red Hat Enterprise Linux Server release 5|Enterprise Linux Enterprise Linux Server 5|Debian GNU/Linux 6|Ubuntu 10
Using install_zs. sh version 8.5 (build: $Revision: 102499 $)
Top packages for installation: zend-server-php-5.6 zend-server-php-5.6-common
Repository was set at /etc/yum.repos.d/zend.repo
Clean installation
Executing: yum install zend-server-php-5.6 zend-server-php-5.6-common
Exit code: 1

Post Reply