Zend Server errors after upgrade to IBM i 7.1 TR11

General discussion on Zend Server for IBM System i
Post Reply
nick8
Posts: 2
Joined: Mon Aug 01, 2016 9:38 am

Zend Server errors after upgrade to IBM i 7.1 TR11

Post by nick8 » Mon Aug 01, 2016 10:21 am

We have recently installed TR11 (we were previously at TR6) and since then our Zend Server instance has been throwing the following errors continuously:

exec(): 0509-036 Cannot load program /usr/local/ZendSvr/bin/php-cgi.bin because of the following errors:
rtld: 0712-001 Symbol EVP_md2 was referenced
from module php-cgi.bin(), but a runtime definition
of the symbol was not found.

We are running an old version of the Community edition of Zend Server (5.0) so I looked to see if I we could upgrade to a more recent version but it looks as if the Community edition doesn't exist anymore(?) Are fixes still being released for it?

nick8
Posts: 2
Joined: Mon Aug 01, 2016 9:38 am

Re: Zend Server errors after upgrade to IBM i 7.1 TR11

Post by nick8 » Mon Aug 01, 2016 11:35 am

Searching around it looks as if although the Community Edition is no more there is still a free 'Basic Edition' licence available for Zend Server so I'm going to investigate installing an up to date version to see it it cures the problem.

Post Reply