Globalization/UTF-8 Setup

General discussion on Zend Server for IBM System i
Post Reply
tinaotto
Posts: 11
Joined: Wed Oct 14, 2009 5:42 pm

Globalization/UTF-8 Setup

Post by tinaotto » Tue Nov 17, 2009 5:03 pm

We are using tables that are setup with a CCSID of 1208 and will be using UTF-8. At some point these tables will contain data in languages other than English. Our system value for CCSID = 65535. I had to follow some procedures to get the conversion of data to occur in our Zend Core/Platform server. How is this done in ZendServer? At this point, I've changed the php.ini file to include default_charset = "UTF-8". I've also issued a chgjob to set the CCSID to 37 prior to starting the ZendServer and Apache jobs. This hasn't fixed the problem.

User avatar
mpavlak
Posts: 8
Joined: Tue Feb 10, 2009 12:58 pm

Re: Globalization/UTF-8 Setup

Post by mpavlak » Tue Nov 17, 2009 7:41 pm

Tina,

I could take a guess, but what exactly is the problem? Are you getting gibberish when you should make Database requests?

tinaotto
Posts: 11
Joined: Wed Oct 14, 2009 5:42 pm

Re: Globalization/UTF-8 Setup

Post by tinaotto » Tue Nov 17, 2009 9:06 pm

The sql statement fails when a where clause is used at part of the statement. It doesn't seem to recognize the data in the file being queried. If I change the system value qccsid to 37 (rather than the default of 65535) and start the servers, the same sql statement works. I don't know that we want to be changing our system value for ccsid on a permanent basis. I need a way to get this to work without having to change the system value.

zend_i5
Posts: 158
Joined: Mon Mar 23, 2009 5:22 pm

Re: Globalization/UTF-8 Setup

Post by zend_i5 » Wed Nov 18, 2009 4:13 pm

Apache FastCGI is IBM product and it is also in Beta version. The GA version of Apache FastCGI PTFs will allow to add language and/or CCSID options to FastCGI configuration file located in /www/zendsvr/conf/fastcgi.conf. The new settings will allow to start the Apache job according to Job CCSID and Language and/or CCSID settings in FastCGI configuration file.

Post Reply