Zend Data Cache does not start

General discussion on Zend Server for IBM System i
Post Reply
rschmitz
Posts: 6
Joined: Tue Jan 05, 2010 2:16 pm

Zend Data Cache does not start

Post by rschmitz » Tue Jan 05, 2010 2:27 pm

After installing Zendserver on our iSeries machine the Zend Data Cache just gives:

Status Error: Could not initialize Zend Data Cache: Fatal error: failed to allocate semaphore. No such file or directory

More detailed in the error_log:

[ 05.01.2010 13:17:26 WARNING] ZShmAllocator::create() Unable to create lock init of sempahore ZShmStorage. No such file or director
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/ZShmStorageshm_init_sem20100105111147694504
[ 05.01.2010 13:17:26 WARNING] ZShmAllocator::create() Unable to create lock init of sempahore ZShmStorage. No such file or director
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/zend_cache_shmstorage.key20100105111147694504
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/jobqueue_rotationSem20100105111147694504
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/jobqueue_rotationSem20100105111147694504
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/ConfigurationChangedEvent20100105111147694504
[ 05.01.2010 13:17:26 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/ConfigurationChangedEvent20100105111147694504
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/monitor_rotationSem20100105111147694504
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/monitor_rotationSem20100105111147694504
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/CollectorUptimeSHMshm_init_sem20100105111147694
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/CollectorUptimeSHMshm_init_sem20100105111147694
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/monitor_agents220100105111147694504
[ 05.01.2010 13:17:27 WARNING] ZSemaphoreImpl::constructor: failed to open file /tmp/monitor_agents220100105111147694504

The logfile are mixed with ASCII and EBCDIC characaters. Is this normal?

Restart and Reset of the environment didn't solve the problem.

User avatar
zvika
Zend Global Support
Posts: 997
Joined: Sun Dec 14, 2008 9:48 am
Contact:

Re: Zend Data Cache does not start

Post by zvika » Thu Jan 07, 2010 2:04 pm

Hi

From what I know you can check the unix environment on the i5 machine, so I will ask for some info:
Stop Zend Server services, then get
# ls -la /tmp
# ipcs -m (if short also ipcs -a)

Please also mention which OS is installed and if you're using beta2 of Zend Server for i5
Please also paste the directives of datacache.ini from Zend server etc dir.

Thanks in advance
Zvika Dror
Zend Support Team

zend_i5
Posts: 158
Joined: Mon Mar 23, 2009 5:22 pm

Re: Zend Data Cache does not start

Post by zend_i5 » Thu Jan 07, 2010 3:38 pm

Here are the steps to reset/clean Zend Server environment:
1. Run option "9. Reset Zend Server environment" from Setup Menu.
2. Stop Zend Server subsystem option 5-> option 2
3. Stop Apache option 5-> option 6
4. Delete Zend Server temp files in /tmp directory
5. Start Zend Server subsystem option 5-> option 1
6. Start Apache option 5-> option 5

rschmitz
Posts: 6
Joined: Tue Jan 05, 2010 2:16 pm

Re: Zend Data Cache does not start

Post by rschmitz » Fri Jan 08, 2010 12:36 pm

Did exactly as requested, cleaned all /tmp files, still the same error.

rschmitz
Posts: 6
Joined: Tue Jan 05, 2010 2:16 pm

Re: Zend Data Cache does not start

Post by rschmitz » Fri Jan 08, 2010 5:22 pm

Sorry, I've overseen your first reply. After stopping the ZendServer the /tmp looks like:

Code: Select all

/tmp>ls -la /tmp
total 9424
drwxrwsrwx   4 qsys     0           2531328 Jan  8 17:16 .
drwxrwsrwx  31 qsys     0           2166784 Jan  5 11:02 ..
srwxr-xr-x   1 qsys     0                 0 May  3 2009  .ct_mc_0_sec14649fcf1af3b47e740
srwxr-xr-x   1 qsys     0                 0 May 10 2009  .ct_mc_0_sec1464a062c4a2b91a408
srwxr-xr-x   1 qsys     0                 0 Jun 14 2009  .ct_mc_0_sec1464a3450cb2c91d9e0
srwxr-xr-x   1 qsys     0                 0 Jul 19 04:22 .ct_mc_0_sec1464a62755926bce2a8
srwxr-xr-x   1 qsys     0                 0 Aug  2 04:23 .ct_mc_0_sec1464a74ea762ab770a8
srwxr-xr-x   1 qsys     0                 0 Dec 20 03:20 .ct_mc_0_sec1464b2d89f11e3d41b8
srwxr-xr-x   1 qsys     0                 0 Aug 30 04:22 .ct_mc_0_sec1474a99d44e24479900
srwxr-xr-x   1 qsys     0                 0 Oct 25 03:22 .ct_mc_0_sec1474ae3b66903e70218
srwxr-xr-x   1 qsys     0                 0 Apr 12 2009  .ct_mc_0_sec14949e1424425ed80d0
srwxr-xr-x   1 qsys     0                 0 Mar 22 2009  .ct_mc_0_sec15649c5a0da05c09478
srwxr-xr-x   1 qsys     0                 0 Mar 13 2009  .ct_mc_0_sec15749ba434735fd51d0
srwxr-xr-x   1 qsys     0                 0 Mar  1 2009  .ct_mc_0_sec15849a9f17a1d3c6bb8
-rw-rw----   1 qtmhhttp 0                 0 Jan  8 12:35 CollectorUptimeSHMshm_init_sem091708121207
drwxrwsrwx   3 191      0              8192 Jan  3 11:10 cache
-rw-rw-rw-   1 nobody   0                 5 Jan  8 12:43 cache_cleaner.pid
-rw-r-----   1 qtmhhttp 0                 0 Jan  8 12:35 jqd_rotationSem091708121207
-rw-rw----   1 qtmhhttp 0                 0 Jan  8 12:35 monitor_node_rotationSem091708121207
-rw-rw----   1 qtmhhttp 0                 0 Jan  8 12:35 qtsharedmemory-436f6c6c6563746f72557074696d6553484d
-rw-rw----   1 qtmhhttp 0                 0 Jan  8 12:35 qtsharedmemory-436f6c6c6563746f72557074696d6553484d5f30
-rw-rw----   1 qtmhhttp 0                 0 Jan  8 12:35 single_monitor_node.sem091708121207
drwxrwsrwx   3 nobody   0             36864 Jan  3 03:58 zend_gui_tmp_files
The results of the ipcs are appended.

The OS is V5R4.

There is no datacache.ini in /usr/local/zendsvr/etc:

Code: Select all

/usr/local/zendsvr/etc>ls -l
total 552
-rwxr-----   1 qtmhhttp 0              8852 Oct 18 17:06 LDB.xml
drwxr-s---   2 qtmhhttp 0             45056 Jan  5 11:06 conf.d
-rwxr-----   1 qtmhhttp 0             14154 Sep  8 10:31 events_rules.xml
-rwxr-----   1 qtmhhttp 0              3234 Apr  1 2009  freetds.conf
-rwxrwx---   1 qtmhhttp 0              1435 Sep 30 13:53 functions.txt
-rwxr-----   1 qtmhhttp 0              1962 Oct 18 17:06 jqd.ini
-rwxr-----   1 qtmhhttp 0              1422 Oct 18 17:06 monitor_node.ini
-rwxr-x---   1 qtmhhttp 0                72 May 25 2008  page_cache_deps.xml
-rwxr-----   1 qtmhhttp 0              1188 Sep  9 13:51 pear.conf
-rwxrwxrwx   1 191      0             49027 Jan  8 12:35 php.ini
-rwxr-----   1 qtmhhttp 0               148 Oct 18 17:06 prngd.conf
-rwxr-----   1 qtmhhttp 0              5726 Aug 24 2008  schema.xsd
-rwxr-----   1 qtmhhttp 0               313 Oct 18 17:06 watchdog-jb.ini
-rwxr-----   1 qtmhhttp 0               123 Oct 18 17:06 watchdog-jq.ini
-rwxr-----   1 qtmhhttp 0               172 Oct 18 17:06 watchdog-monitor.ini
-rwxr-----   1 qtmhhttp 0               353 Jan  5 11:06 zce.rc
-rwxr-----   1 qtmhhttp 0               201 Sep 29 10:37 zem_order
-rwxr-----   1 qtmhhttp 0              2502 Oct 18 17:06 zend_mime_types.ini


Attachments
ipcs_m.txt
(226.28 KiB) Downloaded 513 times
ipcs_a.txt
(564.33 KiB) Downloaded 482 times

User avatar
shlomov
Zend Global Support
Posts: 139
Joined: Mon Dec 29, 2008 2:38 pm

Re: Zend Data Cache does not start

Post by shlomov » Mon Jul 12, 2010 2:32 pm

To follow the instructions make sue you are using QSECOFR.
Shlomo Vanunu
IBM System i

thorstenlehmeier
Posts: 8
Joined: Tue Jun 08, 2010 1:00 pm

Re: Zend Data Cache does not start

Post by thorstenlehmeier » Fri Jul 23, 2010 8:49 am

Hello,

I have the same error. Is it possible to move the tmp directory from /tmp to /usr/local/zendsvr/tmp ?

Best Regards,

Thorsten Lehmeier

User avatar
shlomov
Zend Global Support
Posts: 139
Joined: Mon Dec 29, 2008 2:38 pm

Re: Zend Data Cache does not start

Post by shlomov » Wed Jul 28, 2010 11:48 am

See my post for these i5 server "failed to allocate semaphore" errors.

viewtopic.php?f=8&t=7264
Shlomo Vanunu
IBM System i

philiphugo
Posts: 1
Joined: Thu Jul 29, 2010 8:09 am

Re: Zend Data Cache does not start

Post by philiphugo » Thu Jul 29, 2010 8:13 am

Thanks!

Post Reply