Google API Error #0

General discussion on Zend Server for IBM System i
Post Reply
Posts: 1
Joined: Tue Jul 20, 2010 3:07 pm

Google API Error #0

Post by bill9865321 » Tue Jul 20, 2010 7:25 pm

I am a newbie here and really don't understand AIX or PHP much.

I am getting the following error when I try to test the Google API Zend_Gdata_ClientLogin::getHttpClient API.

PHP Fatal error: Uncaught exception 'Zend_Gdata_App_HttpException' with message 'Unable to Connect to ssl:// Error #0: ' in /usr/local/zendsvr/share/ZendFramework/library/Zend/Gdata/ClientLoogin.php:141

The same code works on a Zend Server running ubuntu.

I tried running the InstallationChecker.php and that gave me the same error too.

Here is my code:
require_once 'Zend/Loader.php';

$client = Zend_Gdata_ClientLogin::getHttpClient('', 'password', Zend_Gdata_Gapps::AUTH_SERVICE_NAME);
$service = new Zend_Gdata_Gapps($client, '');

$userEntry = $service->retrieveUser('someuser');

echo $userEntry->getName();

Any Ideals?

Post Reply